Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452733 - Incorrect file labels for RealPlayer and HelixPlayer
Summary: Incorrect file labels for RealPlayer and HelixPlayer
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 17:46 UTC by Carl Roth
Modified: 2008-11-17 22:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-17 22:04:47 UTC


Attachments (Terms of Use)

Description Carl Roth 2008-06-24 17:46:32 UTC
Description of problem:

RealPlayer and HelixPlayer don't work in selinux enforcing mode because its
binaries and libraries are mislabeled under the current policy.

Also, the labels that are there in the targeted policy appear to have regex bugs
that will prevent them from being applied.

Version-Release number of selected component (if applicable):

HelixPlayer-1.1.0.4327-20080518.amd64
RealPlayer-10.1.0.4326-20080518.amd64
selinux-policy-targeted-3.3.1-64.fc9.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The RPMs available from the RealPlayer and HelixPlayer download sites install by
default into /opt; this should be reflected in the default selinux policy.

AFAIK the correct labels are as follows:

/opt/real/(.*/)?.+\.so(\.[^/]*)* --
gen_context(system_u:object_r:textrel_shlib_t,s0)
/opt/helix/(.*/)?.+\.so(\.[^/]*)* --
gen_context(system_u:object_r:textrel_shlib_t,s0)

/opt/real/(.*/)?realplay[.]bin --
gen_context(system_u:object_r:unconfined_execmem_exec_t,s0)

The /opt/helix/HelixPlayer/hxplay.bin may also need a label too, though I
haven't tested this.

The labels that *do* exist in the policy have a regex bug:

/usr/(.*/)?/RealPlayer/.+\.so(\.[^/]*)*	--	system_u:object_r:textrel_shlib_t:s0
/usr/(.*/)?/HelixPlayer/.+\.so(\.[^/]*)*	--	system_u:object_r:textrel_shlib_t:s0

If you look carefully (and test it with matchpathcon) you can see that this
won't match '/usr/lib/RealPlayer/foo.so' like it should.  A corrected regex would be

/usr/(.*/)?RealPlayer/.+\.so(\.[^/]*)*

Comment 1 Daniel Walsh 2008-06-25 11:14:55 UTC
Fixed in selinux-policy-3.3.1-72.fc9.noarch

Comment 2 Daniel Walsh 2008-11-17 22:04:47 UTC
Closing all bugs that have been in modified for over a month.  Please reopen if the bug is not actually fixed.


Note You need to log in before you can comment on or make changes to this bug.