Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452727 - RFE: SHA1SUM links should be clearly labeled
Summary: RFE: SHA1SUM links should be clearly labeled
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests
Version: devel
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Nick Bebout
QA Contact: Karsten Wade
URL: http://fedoraproject.org/en/verify
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 17:19 UTC by Kam Leo
Modified: 2009-08-05 18:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-05 18:39:56 UTC


Attachments (Terms of Use)

Description Kam Leo 2008-06-24 17:19:46 UTC
Description of problem:

Need to add text to http://fedoraproject.org/en/verify that the links under
"Install DVD / Rescue CD" and "Live Media (both GNOME and KDE)" headings are the
SHA1SUM for each respective spin. Users do not need to "... start by downloading
the proper SHA1SUM file into the same directory as the ISO:". They can also
download the SHA1SUM by clinking the provided links.

Version-Release number of selected component (if applicable):

Fedora 9

How reproducible:
Every time

Steps to Reproduce:
1. Go to http://fedoraproject.org/en/verify
2. 
3.
  
Actual results:

Ambiguous links. Does link "i386" download the iso?

Expected results:

Heading such as "SHA1SUM for Install DVD / Rescue CD" and "SHA1SUM for Live
Media (both GNOME and KDE)"

Additional info:

Comment 1 Kam Leo 2008-06-24 17:43:25 UTC
Read the web page again. The sentence "Otherwise, to verify your ISO, start by
downloading the proper SHA1SUM file into the same directory as the ISO:" and
page lay out added to my confusion. 

Perhaps a two column table would have been better:

column-name:         ISO           SHA1SUM
                     ===========   ========================
                     i386          i386-SHA1SUM-link
                     x86_64        x86_64-SHA1SUM-link
                     ppc           ppc-SHA1SUM-link
                     live_i386     live_i386-SHA1SUM-link
                     live_x86_64   live_x86_6x-SHA1SUM-link


Comment 2 eric@christensenplace.us 2009-06-26 04:37:37 UTC
Can this bug be closed?  The page seems to now show all the proper information for verifying ISOs.

Comment 3 Nick Bebout 2009-06-26 05:41:51 UTC
I would say the description is still applicable, although now the files are called CHECKSUM instead of SHA1SUM.  The reporter is requesting that we clarify the links to say that those are the links to the CHECKSUM files, because it is sort of unclear on if those are the links to the iso's, the directory where the files are stored for each architecture, links to the CHECKSUM files, or what.

I don't know if we really need a table, or just some extra text above the links saying "Here are the links to the CHECKSUM files:" or something.

I would suggest simply adding text like what i mentioned above.

Thoughts/+1's? I can commit/push the change in git if no one objects.

Comment 4 eric@christensenplace.us 2009-06-26 13:23:39 UTC
Sounds like a plan to me.

Comment 5 Ricky Zhou 2009-06-26 14:51:42 UTC
Hey, thanks for looking into this - mind sending a patch to fedora-websites-list like we discussed on IRC?  Thanks!

Comment 6 eric@christensenplace.us 2009-08-05 18:39:56 UTC
If you are still having problems, please go to http://fedoraproject.org/contact to notify the web team of your issue.

Thanks!

Comment 7 eric@christensenplace.us 2009-08-05 18:43:25 UTC
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.


Note You need to log in before you can comment on or make changes to this bug.