Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452676 - %pre failure on install of compiz-fusion-extras-gnome-0.7.6-4.fc10.i386
Summary: %pre failure on install of compiz-fusion-extras-gnome-0.7.6-4.fc10.i386
Keywords:
Status: CLOSED DUPLICATE of bug 452677
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz-fusion-extras
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Adel Gadllah
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 13:47 UTC by Tom London
Modified: 2008-06-24 16:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 16:11:28 UTC


Attachments (Terms of Use)

Description Tom London 2008-06-24 13:47:39 UTC
Description of problem:

Similar problem with compiz-fusion-gnome
(https://bugzilla.redhat.com/show_bug.cgi?id=452674)

/var/tmp/rpm-tmp.78366: line 5: syntax error near unexpected token `do'
/var/tmp/rpm-tmp.78366: line 5: `	do echo /etc/gconf/schemas/compiz-${p}.schemas
; done \'
error: %pre(compiz-fusion-extras-gnome-0.7.6-4.fc10.i386) scriptlet failed, exit
status 2
error:   install: %pre scriptlet failed (2), skipping
compiz-fusion-extras-gnome-0.7.6-4.fc10


Version-Release number of selected component (if applicable):
compiz-fusion-extras-gnome-0.7.6-4.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2008-06-24 13:50:43 UTC
Double 'do' in both %pre and %post at: at end of 'for' and beginning of next line.

[root@localhost packages]# rpm -q --package --scripts
compiz-fusion-extras-gnome-0.7.6-4.fc10.i386.rpm
preinstall scriptlet (using /bin/sh):
if [ "$1" -gt 1 ]; then
  export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`

  for p in in 3d addhelper bench bicubic crashhandler cubeaddon extrawm
fadedesktop firepaint gears group loginout maximumize mblur notification reflex
scalefilter shelf showdesktop showmouse splash trailfocus wallpaper widget; do
	do echo /etc/gconf/schemas/compiz-${p}.schemas ; done \
	| xargs /usr/bin/gconftool-2 --makefile-uninstall-rule >& /dev/null || :

fi
postinstall scriptlet (using /bin/sh):
export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`

for p in in 3d addhelper bench bicubic crashhandler cubeaddon extrawm
fadedesktop firepaint gears group loginout maximumize mblur notification reflex
scalefilter shelf showdesktop showmouse splash trailfocus wallpaper widget; do
do echo /etc/gconf/schemas/compiz-${p}.schemas ; done \
	| xargs /usr/bin/gconftool-2 --makefile-install-rule >& /dev/null || :
preuninstall scriptlet (using /bin/sh):
if [ "$1" -eq 0 ]; then
  export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`

  for p in in 3d addhelper bench bicubic crashhandler cubeaddon extrawm
fadedesktop firepaint gears group loginout maximumize mblur notification reflex
scalefilter shelf showdesktop showmouse splash trailfocus wallpaper widget; do
	do echo /etc/gconf/schemas/compiz-${p}.schemas ; done \
	| xargs /usr/bin/gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  
fi
[root@localhost packages]# 


Comment 2 Adel Gadllah 2008-06-24 16:11:28 UTC

*** This bug has been marked as a duplicate of 452677 ***


Note You need to log in before you can comment on or make changes to this bug.