Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452664 - Anaconda crashs when installing via cdrom using a kickstart available on a nfs server.
Summary: Anaconda crashs when installing via cdrom using a kickstart available on a nf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.3
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Alexander Todorov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 12:33 UTC by Adam Stokes
Modified: 2018-10-17 16:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:35:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
call dhcpNetDevice (deleted)
2008-06-24 12:33 UTC, Adam Stokes
no flags Details | Diff
Adam Stokes' patch updated with one more pumpNetDevice call replacement (deleted)
2008-06-30 12:49 UTC, Radek Vykydal
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0164 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2009-01-20 16:05:24 UTC

Description Adam Stokes 2008-06-24 12:33:58 UTC
Description of problem:
When installing RHEL52 via cdrom using a kickstart file available on a nfs
server, the installer crash.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.113

How reproducible:
100%

Steps to Reproduce:
1. use cdrom to install
2. put ks information on boot prompt
3.
  
Actual results:
Traceback (most recent call first):                                            
 File "/usr/lib/anaconda/network.py", line 341, in lookupHostname
   ret = isys.pumpNetDevice(dev.get('device'), dev.get('dhcpclass'))
 File "/usr/lib/anaconda/network.py", line 531, in write
   ip = self.lookupHostname()
 File "/usr/lib/anaconda/yuminstall.py", line 1401, in doPreInstall
   anaconda.id.network.write(anaconda.rootPath)
 File "/usr/lib/anaconda/backend.py", line 180, in doPreInstall
   anaconda.backend.doPreInstall(anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
   rc = stepFunc(self.anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
   self.moveStep()
 File "/usr/lib/anaconda/text.py", line 588, in run
   anaconda.dispatch.gotoNext()
 File "/usr/bin/anaconda", line 982, in ?
   anaconda.intf.run(anaconda)
AttributeError: 'module' object has no attribute 'pumpNetDevice'


Expected results:
no error

Additional info:
There was a commit that removed pumpNetDevice
commit ea648b05d102ef69c2fc3883bcdaaffabf2d10f9
Author: David Cantrell <dcantrell@redhat.com>
Date:   Tue Apr 8 00:21:54 2008 -1000

   Make isys.dhcpNetDevice() work in rescue mode (#435978).
  
   Remove the isys.pumpNetDevice() function since it's just a
   passthrough for dhcpNetDevice() at this point.  Update the
   function in isys.c to take in None for the class name.  Fix
   the anyUsingDHCP() function in network.py for rescue mode
   and update calls as appropriate.  Update rescue.py to call
   dhcpNetDevice() instead of pumpNetDevice().  And update the
   list of files for the rescue image to include /sbin/dhclient
   and /sbin/dhcp6c and fallbacks for users.

Customer attached a simple patch to call dhcpNetDevice correctly

Comment 1 Adam Stokes 2008-06-24 12:33:59 UTC
Created attachment 310133 [details]
call dhcpNetDevice

Comment 2 RHEL Product and Program Management 2008-06-24 12:49:41 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 3 RHEL Product and Program Management 2008-06-24 14:26:28 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Radek Vykydal 2008-06-30 12:49:53 UTC
Created attachment 310577 [details]
Adam Stokes' patch updated with one more pumpNetDevice call replacement

Comment 7 Radek Vykydal 2008-06-30 12:53:00 UTC
Note on reproducibility:
I had to set some "network --hostname" in ks to hit the issue

Comment 8 Brad Peters 2008-07-16 20:57:10 UTC
Hi Radek, 

How are things looking with this patch?  Is there anything I or IBM can do to help?


Comment 9 Radek Vykydal 2008-07-17 06:48:20 UTC
(In reply to comment #8)
> Hi Radek, 
> 
> How are things looking with this patch?  Is there anything I or IBM can do to
help?
> 

Hi Brad, the patch is ready (attachment form comment #6).


Comment 10 Radek Vykydal 2008-07-22 15:59:52 UTC
resolved with
commit 6ed3d0b3d71c7a3ebe1faa4283782c1bf724abac

Comment 11 Radek Vykydal 2008-09-10 12:26:07 UTC
Included in 11.1.2.116.

Comment 13 Alexander Todorov 2008-11-12 13:46:46 UTC
Performed an install using a Xen guest booting from disc1 and a ks.cfg file on nfs server. Install completed successfully. Moving to VERIFIED.

Comment 15 errata-xmlrpc 2009-01-20 21:35:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html


Note You need to log in before you can comment on or make changes to this bug.