Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452657 - Crash while doing language switch
Summary: Crash while doing language switch
Keywords:
Status: CLOSED DUPLICATE of bug 447444
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 11:38 UTC by Zdenek Kabelac
Modified: 2018-04-11 16:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 17:04:01 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2008-06-24 11:38:00 UTC
Description of problem:

While filling my previous bug report in safe-mode I've got another coredump :)
Again hunspell:

#0  0x000000318260efdb in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
#1  0x0000003cdda2ab21 in nsProfileLock::FatalSignalHandler (signo=<value
optimized out>) at nsProfileLock.cpp:212
#2  <signal handler called>
#3  __libc_free (mem=<value optimized out>) at malloc.c:3599
#4  0x0000003cd8622609 in ~Hunspell (this=<value optimized out>) at hunspell.cxx:81
#5  0x0000003cde1ee59a in mozHunspell::SetDictionary (this=<value optimized
out>, aDictionary=<value optimized out>)
    at mozHunspell.cpp:152
#6  0x0000003cde1e4dd0 in mozSpellChecker::SetCurrentDictionary (this=<value
optimized out>, aDictionary=<value optimized out>)
    at mozSpellChecker.cpp:373
#7  0x0000003cde0dff89 in nsEditorSpellCheck::SetCurrentDictionary (this=<value
optimized out>, 
    aDictionary=<value optimized out>) at nsEditorSpellCheck.cpp:455
#8  0x0000003cde233274 in NS_InvokeByIndex_P (that=<value optimized out>,
methodIndex=<value optimized out>, 
    paramCount=<value optimized out>, params=<value optimized out>) at
xptcinvoke_x86_64_linux.cpp:208
#9  0x0000003cdda4f70c in XPCWrappedNative::CallMethod (ccx=<value optimized
out>, mode=<value optimized out>)
    at xpcwrappednative.cpp:2393
#10 0x0000003cdda58141 in XPC_WN_CallMethod (cx=<value optimized out>,
obj=<value optimized out>, argc=<value optimized out>, 
    argv=<value optimized out>, vp=<value optimized out>) at
xpcwrappednativejsops.cpp:1473
#11 0x0000003cd9e4be5f in js_Invoke (cx=<value optimized out>, argc=<value
optimized out>, vp=<value optimized out>, 
    flags=<value optimized out>) at jsinterp.c:1297
#12 0x0000003cd9e4c20a in js_InternalInvoke (cx=<value optimized out>,
obj=<value optimized out>, fval=<value optimized out>, 
    flags=<value optimized out>, argc=<value optimized out>, argv=<value
optimized out>, rval=<value optimized out>)
    at jsinterp.c:1369
#13 0x0000003cd9e17b81 in JS_CallFunctionValue (cx=<value optimized out>,
obj=<value optimized out>, fval=<value optimized out>, 
    argc=<value optimized out>, argv=<value optimized out>, rval=<value
optimized out>) at jsapi.c:5054
#14 0x0000003cdda5b3c5 in XPC_NW_FunctionWrapper (cx=<value optimized out>,
obj=<value optimized out>, 
    argc=<value optimized out>, argv=<value optimized out>, rval=<value
optimized out>) at XPCNativeWrapper.cpp:442
#15 0x0000003cd9e4be5f in js_Invoke (cx=<value optimized out>, argc=<value
optimized out>, vp=<value optimized out>, 
    flags=<value optimized out>) at jsinterp.c:1297
#16 0x0000003cd9e3ee9f in js_Interpret (cx=0x15ff310) at jsinterp.c:4852
#17 0x0000003cd9e4bea6 in js_Invoke (cx=<value optimized out>, argc=<value
optimized out>, vp=<value optimized out>, 
    flags=<value optimized out>) at jsinterp.c:1313
#18 0x0000003cdda4c808 in nsXPCWrappedJSClass::CallMethod (this=<value optimized
out>, wrapper=<value optimized out>, 
    methodIndex=<value optimized out>, info=<value optimized out>,
nativeParams=<value optimized out>)
    at xpcwrappedjsclass.cpp:1523
#19 0x0000003cde233e61 in PrepareAndDispatch (self=<value optimized out>,
methodIndex=<value optimized out>, 
    args=<value optimized out>, gpregs=<value optimized out>, fpregs=<value
optimized out>) at xptcstubs_x86_64_linux.cpp:151
#20 0x0000003cde23330f in SharedStub () from /usr/lib64/xulrunner-1.9/libxul.so
#21 0x0000003cddd26a80 in nsEventListenerManager::HandleEventSubType
(this=<value optimized out>, 
    aListenerStruct=<value optimized out>, aListener=<value optimized out>,
aDOMEvent=<value optimized out>, 
    aCurrentTarget=<value optimized out>, aPhaseFlags=<value optimized out>) at
nsEventListenerManager.cpp:1080
#22 0x0000003cddd27060 in nsEventListenerManager::HandleEvent (this=<value
optimized out>, aPresContext=<value optimized out>, 
    aEvent=<value optimized out>, aDOMEvent=<value optimized out>,
aCurrentTarget=<value optimized out>, 
    aFlags=<value optimized out>, aEventStatus=Could not find the frame base for
"nsEventListenerManager::HandleEvent(nsPresContext*, nsEvent*, nsIDOMEvent**,
nsISupports*, unsigned int, nsEventStatus*)".
) at nsEventListenerManager.cpp:1184
#23 0x0000003cddd40009 in nsEventTargetChainItem::HandleEvent (this=<value
optimized out>, aVisitor=<value optimized out>, 
    aFlags=<value optimized out>) at nsEventDispatcher.cpp:210
#24 0x0000003cddd40122 in nsEventTargetChainItem::HandleEventTargetChain
(this=<value optimized out>, 
    aVisitor=<value optimized out>, aFlags=<value optimized out>,
aCallback=<value optimized out>) at nsEventDispatcher.cpp:268
#25 0x0000003cddd404b7 in nsEventDispatcher::Dispatch (aTarget=<value optimized
out>, aPresContext=<value optimized out>, 
    aEvent=<value optimized out>, aDOMEvent=<value optimized out>,
aEventStatus=<value optimized out>, 
    aCallback=<value optimized out>) at nsEventDispatcher.cpp:483
#26 0x0000003cddbaa47f in PresShell::HandleDOMEventWithTarget (this=<value
optimized out>, aTargetContent=<value optimized out>, 
    aEvent=<value optimized out>, aStatus=<value optimized out>) at
nsPresShell.cpp:5967
#27 0x0000003cddcb612c in nsXULMenuCommandEvent::Run (this=<value optimized
out>) at nsXULPopupManager.cpp:2068
#28 0x0000003cde227d56 in nsThread::ProcessNextEvent (this=<value optimized
out>, mayWait=<value optimized out>, 
    result=<value optimized out>) at nsThread.cpp:510
#29 0x0000003cde1f95b6 in NS_ProcessNextEvent_P (thread=<value optimized out>,
mayWait=<value optimized out>)
---Type <return> to continue, or q <return> to quit--- 
    at nsThreadUtils.cpp:227
#30 0x0000003cde17036d in nsBaseAppShell::Run (this=<value optimized out>) at
nsBaseAppShell.cpp:170
#31 0x0000003cde02e0bd in nsAppStartup::Run (this=<value optimized out>) at
nsAppStartup.cpp:181
#32 0x0000003cdda2398f in XRE_main (argc=<value optimized out>, argv=<value
optimized out>, aAppData=<value optimized out>)
    at nsAppRunner.cpp:3170
#33 0x0000000000401665 in main (argc=4, argv=0x7fffcdcacc88) at nsXULStub.cpp:364


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. trying to switch language spell checking for the FORM 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Zdenek Kabelac 2008-06-24 11:42:41 UTC
Looks like it is related to #447444.

Thought for me it's not crashing while I type - just when I try to switch settings.

Comment 2 Zdenek Kabelac 2008-06-24 14:31:52 UTC
Maybe this coredump backtrace might be also useful:

#0  0x000000318260efdb in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
#1  0x00007f83c2366b21 in nsProfileLock::FatalSignalHandler (signo=<value
optimized out>) at nsProfileLock.cpp:212
#2  <signal handler called>
#3  __libc_free (mem=<value optimized out>) at malloc.c:3599
#4  0x00007f83c1ad5b19 in ~SuggestMgr (this=<value optimized out>) at
suggestmgr.cxx:92
#5  0x00007f83c1ad5551 in ~Hunspell (this=<value optimized out>) at hunspell.cxx:69
#6  0x00007f83c2b2a849 in ~mozHunspell (this=<value optimized out>) at
mozHunspell.cpp:103
#7  0x00007f83c2b296f0 in mozHunspell::Release (this=<value optimized out>) at
mozHunspell.cpp:78
#8  0x00007f83c2b5d12c in FreeServiceContractIDEntryEnumerate (aTable=<value
optimized out>, aHdr=<value optimized out>, 
    aNumber=<value optimized out>, aData=<value optimized out>) at
../../dist/include/xpcom/nsCOMPtr.h:1060
#9  0x00007f83c2b2f8d6 in PL_DHashTableEnumerate (table=<value optimized out>,
etor=<value optimized out>, 
    arg=<value optimized out>) at pldhash.c:724
#10 0x00007f83c2b5d571 in nsComponentManagerImpl::FreeServices (this=<value
optimized out>)
    at nsComponentManager.cpp:1820
#11 0x00007f83c2b38577 in NS_ShutdownXPCOM_P (servMgr=<value optimized out>) at
nsXPComInit.cpp:775
#12 0x00007f83c235d0f7 in ~ScopedXPCOMStartup (this=<value optimized out>) at
nsAppRunner.cpp:909
#13 0x00007f83c235fa42 in XRE_main (argc=<value optimized out>, argv=<value
optimized out>, 
    aAppData=<value optimized out>) at nsAppRunner.cpp:3211
#14 0x0000000000401665 in main (argc=3, argv=0x7fffcb976d28) at nsXULStub.cpp:364


Comment 3 Matěj Cepl 2008-06-24 17:04:01 UTC
I think all these are more or less dup of the bug I am closing it against.

*** This bug has been marked as a duplicate of 447444 ***


Note You need to log in before you can comment on or make changes to this bug.