Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452656 - Deadlock during exit of FF3
Summary: Deadlock during exit of FF3
Keywords:
Status: CLOSED DUPLICATE of bug 447444
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 11:32 UTC by Zdenek Kabelac
Modified: 2018-04-11 07:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 17:01:51 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2008-06-24 11:32:54 UTC
Description of problem:

While using ff with -safe-mode   and doing ff exit it stayed crashed:

Here is backtrace from the attached gdb to the locked ff3
Might be a bug in libhunspell....

#0  0x0000003181af6f6e in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x0000003181a7fa75 in _L_lock_4812 () from /lib64/libc.so.6
#2  0x0000003181a7becb in __libc_free (mem=<value optimized out>)
    at malloc.c:3623
#3  0x00007fa7799b08a4 in nsProfileLock::Unlock (this=0x6b2e48)
    at nsProfileLock.cpp:658
#4  0x00007fa7799b08d9 in nsProfileLock::RemovePidLockFiles ()
    at nsProfileLock.cpp:150
#5  0x00007fa7799b0a80 in nsProfileLock::FatalSignalHandler (signo=-2116617728)
    at nsProfileLock.cpp:165
#6  <signal handler called>
#7  0x0000003181a32fa5 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x0000003181a34b13 in abort () at abort.c:88
#9  0x0000003181a73f38 in __libc_message (do_abort=<value optimized out>, 
    fmt=<value optimized out>) at ../sysdeps/unix/sysv/linux/libc_fatal.c:170
#10 0x0000003181a79898 in malloc_printerr (action=<value optimized out>, 
    str=<value optimized out>, ptr=<value optimized out>) at malloc.c:5949
#11 0x0000003181a7bed6 in __libc_free (mem=<value optimized out>)
    at malloc.c:3625
#12 0x00007fa77911f5ed in ~Hunspell (this=0x2f06d50) at hunspell.cxx:79
#13 0x00007fa77a174849 in ~mozHunspell (this=0x2f06890) at mozHunspell.cpp:103
#14 0x00007fa77a1736f0 in mozHunspell::Release (this=0x2981)
    at mozHunspell.cpp:78
#15 0x00007fa77a1a712c in FreeServiceContractIDEntryEnumerate (
    aTable=<value optimized out>, aHdr=<value optimized out>, aNumber=6, 
    aData=0xffffffffffffffff) at ../../dist/include/xpcom/nsCOMPtr.h:1060
#16 0x00007fa77a1798d6 in PL_DHashTableEnumerate (table=0x6afc58, 
    etor=0x7fa77a1a7114 <FreeServiceContractIDEntryEnumerate>, arg=0x0)
    at pldhash.c:724
#17 0x00007fa77a1a7571 in nsComponentManagerImpl::FreeServices (this=0x6afbe0)
    at nsComponentManager.cpp:1820
#18 0x00007fa77a182577 in NS_ShutdownXPCOM_P (servMgr=0x6afbe8)
    at nsXPComInit.cpp:775
#19 0x00007fa7799a70f7 in ~ScopedXPCOMStartup (this=0x7fff82fbb9b0)
    at nsAppRunner.cpp:909
#20 0x00007fa7799a9a42 in XRE_main (argc=<value optimized out>, 
    argv=<value optimized out>, aAppData=<value optimized out>)
    at nsAppRunner.cpp:3211
#21 0x0000000000401665 in main (argc=4, argv=0x7fff82fbef78)
    at nsXULStub.cpp:364


Version-Release number of selected component (if applicable):
firefox-3.0-1.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.kill Xorg while ff3 is running
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-06-24 17:01:51 UTC

*** This bug has been marked as a duplicate of 447444 ***


Note You need to log in before you can comment on or make changes to this bug.