Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452640 - error when virt-manager try connect to guest system
Summary: error when virt-manager try connect to guest system
Keywords:
Status: CLOSED DUPLICATE of bug 459927
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 08:08 UTC by Kamil Pawlowski
Modified: 2009-06-27 15:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-03 20:36:05 UTC


Attachments (Terms of Use)

Description Kamil Pawlowski 2008-06-24 08:08:23 UTC
I get error when virt-manager try connect to guest system screen (After create
or when I click on open). So virt-manager is unusable, because I can't see anything 

$ virt-manager --no-fork 
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value
"((GString*) 0x7f906f5e7120)" of type `GString'
The program 'virt-manager.py' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadLength (poly request too large or internal Xlib length erro'.
  (Details: serial 3057 error_code 16 request_code 143 minor_code 17)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

$ virt-manager --sync --no-fork 
Usage: virt-manager.py [options]

virt-manager.py: error: no such option: --sync

Comment 1 Torsten Rausche 2008-08-27 11:26:12 UTC
Please try

$ LANG=C virt-manager --no-fork

More details can be found in bug 459927. I think this is the same error. If so one of the bug reports can be closed as duplicate. Either this one because the other one has more details or the other one because this one is older.

Comment 2 Cole Robinson 2008-09-03 20:36:05 UTC

*** This bug has been marked as a duplicate of bug 459927 ***


Note You need to log in before you can comment on or make changes to this bug.