Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452615 - mga driver prevents normal bootup/login
Summary: mga driver prevents normal bootup/login
Keywords:
Status: CLOSED DUPLICATE of bug 442533
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 02:47 UTC by Tim Malnati
Modified: 2008-11-14 17:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-14 17:46:46 UTC


Attachments (Terms of Use)

Description Tim Malnati 2008-06-24 02:47:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Description of problem:
mga driver does not display resolutions > 800 x 600 @ 60hz.  Default resolution is based on the connected monitor which usually support higher resolutions.  The mga driver causes the display card to push frequencies that the monitor is NOT capable of displaying.  The result is that users who have mga related hardware will NOT be able to access their machines via normal means.  The only known interim workarounds are to (1) boot up in single user mode -or- (2) boot up with no monitor attached so that driver selects 800 x 600 @ 60hz mode (unknown monitor).  Logout requires a reboot as well.  Neither of these are workable where many applications and utilities require greater resolution.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.8-1

How reproducible:
Always


Steps to Reproduce:
upgrade installation of fc9 (from fc8)

Actual Results:
Unable to see monitor screen where an invalid scan frequency is attempting to display

Expected Results:
At least something readable on the screen

Additional info:
THIS IS A HIGH PRIORITY ITEM.  A similar ticket exists (442533) but this stale ticket gets no response from additions.

Comment 1 Tim Malnati 2008-06-24 03:20:01 UTC
Attempt to revert to fc8 mga driver DOES NOT WORK either.  Monitor screen
flashes about 5 times and only allows text login.  Pushing init 5 causes the
machine to display the error (0x0c:ox005) failed to create listening socket. 
Re-installation of fc9 reproduces problem.  (normal text mode is displayed
properly during boot. issue appears when machine attempts to graphical (udev
starts) - grub graphics are normal)

Comment 2 Tim Malnati 2008-06-25 16:56:31 UTC
ajax@redhat.com closed this ticket without justification.  This issue continues.

Comment 3 Will Woods 2008-11-14 17:46:46 UTC

*** This bug has been marked as a duplicate of bug 442533 ***


Note You need to log in before you can comment on or make changes to this bug.