Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452612 - Network Bonding doesn't work with ehea driver
Summary: Network Bonding doesn't work with ehea driver
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.6
Hardware: ppc64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Jiri Pirko
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 02:05 UTC by Nate Golnik
Modified: 2012-05-07 20:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-07 18:39:44 UTC


Attachments (Terms of Use)

Description Nate Golnik 2008-06-24 02:05:56 UTC
Description of problem:
Using a P6-570 there is no link monitoring for the ehea network interfaces. 
Which causes issues with bonding.

Version-Release number of selected component (if applicable):
RHEL 4.6, IBM P6-570 

How reproducible:
always

Steps to Reproduce:
1.add the following lines to modprobe.conf:
  alias bond0 bonding
  options bond0 miimon=100 max_bonds=2 mode=1

2. Configure eth0 and eth1 as slaves to bond0
3. Configure bond0
4. load bonding modules and restart networking
  
Actual results:

network: Bringing up interface bond0:  succeeded
ifup: Enslaving eth0 to bond0 
ifup: Enslaving eth1 to bond0 
network: Bringing up interface bond0:  succeeded 
kernel: bonding: MII link monitoring set to 100 ms
kernel: bonding: Warning : no link monitoring support for eth0
kernel: bonding: Warning : no link monitoring support for eth1

no traffic will pass over the interface (kind of expected with no link
monitoring working)

Expected results:
Link monitoring support for eth0 and eth1 and a functioning bonded interface

Additional info:
none

Comment 1 Neil Horman 2010-11-10 16:09:10 UTC
Triage assignment.  If you feel this bug doesn't belong to you, or that it cannot be handled in a timely fashion, please contact me for re-assignment

Comment 2 Jiri Pirko 2010-12-07 10:32:58 UTC
Interesting. The warning message is printed out in bond_enslave() at the very beginning of this function by following code:

if (!bond->params.use_carrier && slave_dev->ethtool_ops == NULL &&
    slave_dev->do_ioctl == NULL) {
        printk(KERN_WARNING DRV_NAME
               ": Warning : no link monitoring support for %s\n",
               slave_dev->name);
}

But slave_dev->ethtool_ops should not be null, because it is set in drivers/net/ehea/ehea_ethtool.c function ehea_set_ethtool_ops()

Am I missing something?

Are you sure you are experiencing this with ehea driver?

Comment 3 Rashid Khan 2012-05-07 18:39:44 UTC
Due to resource constraints or complexity, this issue could not be resolved in the time frame of this release.
Kindly please try RHEL 6.3 Beta and see if the problem still happens in that release. If it does please start a new bug. 
If you feel you cannot move to that release, please contact your Global Support Specialist for further escalation and prioritization. 
Kind Regards.

Comment 4 Rashid Khan 2012-05-07 20:18:05 UTC
Due to resource constraints or complexity, this issue could not be resolved in
the time frame of this release.
Kindly please try RHEL 6.3 Beta or 5.8 and see if the problem still happens in that
release. If it does please start a new bug. 
If you feel you cannot move to that release, please contact your Global Support
Specialist for further escalation and prioritization. 
Kind Regards.


Note You need to log in before you can comment on or make changes to this bug.