Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452591 - sqlite-devel compiled with incorrect gcc flag fast math
Summary: sqlite-devel compiled with incorrect gcc flag fast math
Keywords:
Status: CLOSED DUPLICATE of bug 474260
Alias: None
Product: Fedora
Classification: Fedora
Component: sqlite
Version: 10
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-06-23 22:35 UTC by Mike Chirico
Modified: 2009-01-29 08:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-29 08:03:57 UTC


Attachments (Terms of Use)

Description Mike Chirico 2008-06-23 22:35:16 UTC
Description of problem:

SQLite 3 will not correct perform calculations on real numbers.


Version-Release number of selected component (if applicable):

Name       : sqlite-devel
Arch       : i386
Version    : 3.5.9
Release    : 1.fc10


How reproducible:


Steps to Reproduce:

1. Run sqlite3
3. Perform simple select 
select 5/9.0;
  
Actual results:

Returns a null result. A faction should be returned.
Expected results:

sqlite> select 5/9.0;
0.555555555555556


Additional info:

sqlite3 was compiled with the gcc fast math option by default. This is incorrect.

Fix (forcing no-fast-math):

$ export CFLAGS=-fno-fast-math
$ ./configure
$ make


Without this setting, the following tests failed, when running

$ make test

19 errors out of 58547 tests

Failures on these tests: expr-2.3 expr-2.4 expr-2.5 func-18.13 main-3.2.22
main-3.2.23 
main-3.2.24 main-3.3 misc3-2.1 misc3-2.2 misc3-2.3 misc3-2.4 misc3-2.5 misc3-2.6
misc3-2.7 
misc3-2.8 misc3-2.9 select6-3.3 select6-3.6


After setting this flag:

0 errors out of 62272 tests


Note:

It appears that Fedora release 9.90 (Rawhide) has fixed the problem
with the compiler; however, they are distributing SQLite with a
version that hasn't be compiled with this flag.

Comment 1 Bug Zapper 2008-11-26 02:27:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Panu Matilainen 2009-01-29 08:03:57 UTC
Hum, this has been reported against "sqlite3" component, which doesn't really exist (sqlite is the right one) and the owner email is long since invalid, so this gone completely unnoticed :-/

Anyway, this is dupe of 474260.

*** This bug has been marked as a duplicate of bug 474260 ***


Note You need to log in before you can comment on or make changes to this bug.