Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452586 - Queries are not synchronized
Summary: Queries are not synchronized
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 21:46 UTC by Matěj Cepl
Modified: 2018-04-11 19:12 UTC (History)
1 user (show)

Fixed In Version: eclipse-mylyn-3.1.0-3.fc11.noarch
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-16 18:00:32 UTC


Attachments (Terms of Use)
screenshot of reproduction (deleted)
2008-06-23 21:46 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2008-06-23 21:46:28 UTC
Description of problem:
I would like to have in bugzilla-mylyn tasks couple of my standard queries
(especially,
https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=Gecko%20NEW&namedowner=mcepl%40redhat.com,
https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=XGL%20NEW&namedowner=mcepl%40redhat.com,
and
https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&namedcmd=old%20NEEDINFOs&namedowner=mcepl%40redhat.com)
However, when I try to synchronize Red Hat Bugzilla repository, it gets into
"Task Synchronization (2799 tasks)" (which probably relates to Unmatched tasks)
and then it either fails with error about webserver timeout, or once I got some
error message about exhausted Java heap memory. When I try to run just one query
(which is marked as failed) "old NEEDINFO" (the last one from those above), I
get attached very helpful message in the screen.

Version-Release number of selected component (if applicable):
[matej@viklef ~]$ rpm -qa eclipse\*
eclipse-mylyn-2.3.2-6.fc9.i386
eclipse-mylyn-bugzilla-2.3.2-6.fc9.i386
eclipse-platform-3.3.2-12.fc9.i386
eclipse-mylyn-ide-2.3.2-6.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
cannot use Eclipse for my work

Expected results:
synchronized state of my bugzilla bugs, joy, and prosperity ;-)

Comment 1 Matěj Cepl 2008-06-23 21:46:28 UTC
Created attachment 310078 [details]
screenshot of reproduction

Comment 2 Andrew Overholt 2008-06-24 17:19:51 UTC
Re-assigning to proper component.

Red Hat bugzilla is not properly supported by Mylyn upstream because of various
customizations.  I had been waiting on the forthcoming move to 3.0 but seeing as
that isn't happening as quickly as I had expected, I've begun work on a custom
Red Hat bugzilla connector for Mylyn.  See
https://bugs.eclipse.org/bugs/show_bug.cgi?id=132291 for more information.

Comment 4 Andrew Overholt 2008-11-07 23:51:45 UTC
I have better luck getting Red Hat bugzilla to work from outside the Red Hat network but there seems to be an awful timeout requesting the products list.  I'm trying to track this down.  (I'm writing this from Mylyn right now FWIW)

Comment 5 Matěj Cepl 2009-05-16 18:00:32 UTC
Works for me with eclipse-mylyn-3.1.0-3.fc11.noarch


Note You need to log in before you can comment on or make changes to this bug.