Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452568 - all X applications fail with X error: cannot find font
Summary: all X applications fail with X error: cannot find font
Keywords:
Status: CLOSED DUPLICATE of bug 430416
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 9
Hardware: i386
OS: Linux
low
urgent
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 19:24 UTC by Sam Steingold
Modified: 2018-04-11 16:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 16:50:16 UTC


Attachments (Terms of Use)

Description Sam Steingold 2008-06-23 19:24:50 UTC
Description of problem:

most X applications fail with an X error saying that it cannot find an object.
it turns out the that object is usually a font.
this means that when I start X, all I see is a blank screen - no nautilus, no
panels, no way to start a gnome-terminal or an xterm or firefox.
(I am typing this on another machine, and I do not have ssh access to the
problematic machine atm).
the X log also indicates errors to load modules "record" and "type1".
(apparently, "type1" has been subsumed into "freetype" - what about "record"?).
I have many font packages installed, including the type1 font package.


Version-Release number of selected component (if applicable):

latest ("yum -u upgrade" nightly)

How reproducible:

always

Steps to Reproduce:
1.start x
2.
3.
  
Actual results:
blank X screen, no desktop icons (like home, computer, trash), no panels.
just the mouse pointer which can be moved but which has not thing to click on.

Expected results:
X screen with panels, icons, menues &c.

Additional info:

Comment 1 Nicolas Mailhot 2008-06-23 20:45:56 UTC
xorg-x11-fonts is old and inappropriate for most modern apps (only used by some
legacy stuff)

Do you actually have any current font package such as dejavu-fonts,
dejavu-fonts-experimental or liberation-fonts installed on system?


Comment 2 Matěj Cepl 2008-06-23 21:57:10 UTC
Let's make more explicit test; reporter, could you please post output of the
command:

rpm -qa \*fonts\*

Thank you.

Comment 3 Sam Steingold 2008-06-23 22:46:18 UTC
$ rpm -qa \*fonts\*
fonts-KOI8-R-1.0-10.fc8.noarch
fonts-KOI8-R-100dpi-1.0-10.fc8.noarch
bitstream-vera-fonts-1.10-8.noarch
xorg-x11-fonts-cyrillic-7.2-6.fc9.noarch
texlive-texmf-errata-fonts-2007-4.fc9.noarch
liberation-fonts-1.0-4.fc9.noarch
xorg-x11-fonts-75dpi-7.2-6.fc9.noarch
ghostscript-fonts-5.50-18.fc8.noarch
dejavu-lgc-fonts-2.24-3.fc9.noarch
xorg-x11-fonts-Type1-7.2-6.fc9.noarch
mplayer-fonts-1.1-3.0.rf.noarch
xorg-x11-fonts-ISO8859-15-75dpi-7.2-6.fc9.noarch
mathml-fonts-1.0-21.fc6.noarch
fonts-hebrew-0.101-2.fc8.noarch
xorg-x11-fonts-misc-7.2-6.fc9.noarch
xorg-x11-fonts-100dpi-7.2-6.fc9.noarch
texlive-texmf-fonts-2007-22.fc9.noarch
xorg-x11-fonts-truetype-7.2-3.fc8.noarch
urw-fonts-2.4-5.fc9.noarch
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
xorg-x11-fonts-ISO8859-15-100dpi-7.2-6.fc9.noarch
culmus-fonts-0.101-4.fc8.noarch
xorg-x11-fonts-ISO8859-1-100dpi-7.2-6.fc9.noarch
bitmap-fonts-0.3-5.2.fc9.noarch
$

Comment 4 Sam Steingold 2008-06-23 22:50:03 UTC
specific errors:

The program 'nautilus' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 264 error_code 15 request_code 45 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Window manager warning: xserver doesn't have 'fixed' font.
Bug in window manager: Unexpected X error: BadName (named color or font does not
exist) serial 209 error_code 15 request_code 45 minor_code 0)
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xa75767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xa7590e]
#2 /usr/lib/libX11.so.6 [0xac8109]
#3 /usr/lib/libX11.so.6(XUngrabPointer+0x25) [0xabdd55]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_display_pointer_ungrab+0xba) [0x25d3f54]
#5 /usr/lib/libgdk-x11-2.0.so.0(gdk_pointer_ungrab+0x1c) [0x25aadd9]
#6 /usr/lib/gtk-2.0/modules/libgnomebreakpad.so [0x15036e]
#7
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so(_ZN15google_breakpad16ExceptionHandler21InternalWriteMinidumpEijPP10sigcontext+0x43)
[0x150893]
#8
/usr/lib/gtk-2.0/modules/libgnomebreakpad.so(_ZN15google_breakpad16ExceptionHandler15HandleExceptionEi+0xa3)
[0x150e23]
#9 [0x110420]
#10 /lib/libc.so.6(abort+0x188) [0x7b4028]
#11 metacity [0x807dbc6]
#12 metacity [0x80675e2]
#13 /usr/lib/libX11.so.6(_XError+0x109) [0xac0a49]
#14 /usr/lib/libX11.so.6 [0xac8ac8]
#15 /usr/lib/libX11.so.6(_XEventsQueued+0x55) [0xac9435]
#16 /usr/lib/libX11.so.6(_XFlush+0x42) [0xac94c2]
#17 /usr/lib/libX11.so.6(XFlush+0x31) [0xaa0b41]
#18 metacity [0x807661f]
#19 metacity [0x8077791]



Comment 5 Nicolas Mailhot 2008-06-24 07:31:14 UTC
That makes it an xorg problem (I think)

Comment 6 Matěj Cepl 2008-06-25 16:50:16 UTC

*** This bug has been marked as a duplicate of 430416 ***


Note You need to log in before you can comment on or make changes to this bug.