Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452557 - hald-addon-input using 100% of a core
Summary: hald-addon-input using 100% of a core
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 18:04 UTC by John Westlund
Modified: 2013-03-06 03:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-11 16:55:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 203679 None None None Never

Description John Westlund 2008-06-23 18:04:08 UTC
Description of problem:
Sometimes after a certain while after fresh boot top shows something like the
following:

top - 17:26:06 up 2:03, 2 users, load average: 2.93, 3.12, 3.17
Tasks: 112 total, 5 running, 107 sleeping, 0 stopped, 0 zombie
Cpu(s): 48.8%us, 40.9%sy, 10.3%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 1034360k total, 1018448k used, 15912k free, 42412k buffers
Swap: 2931852k total, 38192k used, 2893660k free, 572028k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 5225 root 20 0 3436 1328 1160 R 80.8 0.1 73:14.44 hald-addon-inpu
 9102 root 30 10 77552 74m 1464 R 8.0 7.3 5:33.33 scrollkeeper-up
 6207 root 20 0 163m 25m 10m S 3.7 2.5 6:47.18 Xorg

It has to be killed because it doesn't stop by itself even after many minutes.

Version-Release number of selected component (if applicable):
hal-0.5.10-1.fc8.2

How reproducible:
Occurs sometime after boot appears to be aggravated by wireless/bluetooth devices.

Comment 1 Ben Woodard 2008-07-08 19:49:27 UTC
http://bugzilla.kernel.org/show_bug.cgi?id=9027



Comment 3 Ben Woodard 2008-07-08 19:53:34 UTC
Date: Mon, 07 Jul 2008 13:57:19 -0700
From: John Westlund <john.westlund@llnl.gov>
User-Agent: Thunderbird 2.0.0.14 (X11/20080421)
MIME-Version: 1.0
To: Ben Woodard <bwoodard@llnl.gov>
Subject: Bugzilla Bug 452557: hald-addon-input using 100% of a core
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Hey Ben,

If you get a chance could you see if you could get this low hanging 
fruit knocked off?  Two-line patch, very straight forward.

Bugzilla is pretty empty, the Ubuntu ticket has more details and the patch.

John


Comment 4 Ben Woodard 2008-07-08 20:51:54 UTC
https://bugs.launchpad.net/ubuntu/+bug/203679

Comment 5 David Zeuthen 2008-07-18 18:09:55 UTC
* Fri Jul 18 2008 David Zeuthen <davidz@redhat.com> - 0.5.10-4
- fix runaway input add-on (#452557)

http://koji.fedoraproject.org/koji/taskinfo?taskID=725357


Comment 6 Fedora Update System 2008-07-18 18:25:39 UTC
hal-0.5.10-4.fc8 has been submitted as an update for Fedora 8

Comment 7 Fedora Update System 2008-07-19 09:44:02 UTC
hal-0.5.10-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hal'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6553

Comment 8 Fedora Update System 2008-09-11 16:55:06 UTC
hal-0.5.10-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.