Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452550 - dhcpd no longer starts from startup script
Summary: dhcpd no longer starts from startup script
Keywords:
Status: CLOSED DUPLICATE of bug 448014
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp
Version: 5.2
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On: 448014
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 17:38 UTC by Colin.Simpson
Modified: 2008-06-25 13:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 13:15:13 UTC


Attachments (Terms of Use)

Description Colin.Simpson 2008-06-23 17:38:14 UTC
Description of problem:
On boot or by running command /etc/init.d/dhcpd start, dhcpd
claims to start but isn't running when you ps for it.

Version-Release number of selected component (if applicable):
Version RH Enterprise Linux Server release 5.2

How reproducible:
Every time

Steps to Reproduce:
1. Run /etc/init.d/dhcpd restart
2. Claims to have started.
3. ps -ef  |grep dhcp , it isn't running. 
  
Actual results:
This seems to be a regression, as it worked in 5.1, failed on 5.2 update.

Expected results:
Daemon to be running. 

Additional info:

The daemon seems to start up i.e it puts the correct log entries into
/var/log/messages. It looks like it's the forked child that dies. The program
runs fine with a "-f" flag put in. In fact my present workaround is rather
horrible with:

daemon $dhcpd $DHCPDARGS -f 2>/dev/null &
, in the startup file.

Comment 1 Colin.Simpson 2008-06-25 09:32:43 UTC
Replying to my own problem, this seem to be related to and caused by Bug
#448014. Downgrading to nss_ldap-253-5.el5 resolved this issue. 

Comment 2 David Cantrell 2008-06-25 13:15:13 UTC

*** This bug has been marked as a duplicate of 448014 ***


Note You need to log in before you can comment on or make changes to this bug.