Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452545 - GRUB intolerant of pre-existing Ubuntu and Debian installations.
Summary: GRUB intolerant of pre-existing Ubuntu and Debian installations.
Keywords:
Status: CLOSED DUPLICATE of bug 334701
Alias: None
Product: Fedora
Classification: Fedora
Component: grub
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 17:15 UTC by Gloria W
Modified: 2009-04-22 22:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-04-22 22:17:21 UTC


Attachments (Terms of Use)

Description Gloria W 2008-06-23 17:15:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
Installing Fedora 9, and it's associated GRUB to the MBR, on dual-boot system (in attempt to make it a tri-boot system), with a pre-existing and functional Debian 4 and Ubuntu 8 OS issues no errors. 

But upon reboot, fedora 9 GRUB fails to correctly detect and boot Debian and Ubuntu (which previously dual-booted from the MBR successfully). Manually changing GRUBs lst file and rebooting does not fix the problem. GRUB reports and invalid boot sector for both. 

Overwriting GRUB with the Debian distribution of GRUB in the MBR makes Ubuntu and Debian accessible again, but fails to boot Fedora 9. Seems that the three cannot co-exist in the boot loader. 

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.Load Ubuntu 8, and Debian 4 on different partitions. 
2.Use either Debian or Ubuntu GRUB boot laoder to boot them (it does not matter which one).
3. Load Fedora 9 on a separate partition. Overwrite the GRUB boot loader with the Fedora distribution GRUB. 
4. Then try reinstalling the Ubuntu/Debian GRUB boot loader for the second problem. 

Actual Results:
Could not access Ubuntu/Debian parititions.

Expected Results:
A successful GRUB install and tri-boot system.

Additional info:
Installed on a 2 year old Dell Dimension Intel Dual Core with 1 gig of memory, where Fedora 9 alone runs perfectly.

Comment 1 Christopher Beland 2009-04-22 22:17:21 UTC
Thank you for the bug report.  This looks like a subset of bug 334701, so I'll mark this as a duplicate and ask around about what to do about this issue.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 334701 ***


Note You need to log in before you can comment on or make changes to this bug.