Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452525 - JNLP PersitenceService does not trigger FileNotFoundException as the documented on the API
Summary: JNLP PersitenceService does not trigger FileNotFoundException as the document...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Joshua Sumali
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 15:12 UTC by Robert Marcano
Modified: 2008-07-15 15:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 15:52:41 UTC


Attachments (Terms of Use)

Description Robert Marcano 2008-06-23 15:12:48 UTC
Description of problem:

The JNLP javadoc says that when retrieving the contents of a file, it must
trigger a FileNotFoundException if the store is not found, the current NetX
implementation return a dummy FileContents that later trigger the
FileNotFoundException when calling getInputStream(). This cause problems with
code that check if the store is created with the PersitenceService>>get() method
before calling getInputStream()

http://java.sun.com/products/javawebstart/1.0.1/javadoc/javax/jnlp/PersistenceService.html#get(java.net.URL)


Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-0.15.b09.fc9.i386

Steps to Reproduce:
1.Clear all netx cache and .netx directory
2.Call PersistenceService>>get()
3.It must signal a FileNotFoundException because never has been created a
persistence store
  
Actual results:
No exception is thrown calling PersistenceService>>get(), only after calling
getInputStream()

Caused by: java.io.FileNotFoundException: [path to file here] (No such file or
directory)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:137)
	at
net.sourceforge.jnlp.services.XFileContents.getInputStream(XFileContents.java:68)
	... 20 more

Expected results:
FileNotFoundException when calling PersistenceService>>get() if the store has
not been created

Comment 1 Joshua Sumali 2008-06-27 17:05:03 UTC
Hi,

Thanks for reporting this bug. It has been fixed in the IcedTea repository.

Comment 2 Robert Marcano 2008-06-27 17:45:46 UTC
thanks to you for the fix, I still have a few other bugs that I am investigating
workarounds in our application. I will report them after developing a few testcases

Comment 3 Lillian Angel 2008-07-15 15:52:41 UTC
Updated in rawhide, will be in soon.


Note You need to log in before you can comment on or make changes to this bug.