Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452492 - NetworkManager fills syslog with killswitch errors
Summary: NetworkManager fills syslog with killswitch errors
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 12:38 UTC by Johan Vromans
Modified: 2008-11-02 22:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-02 22:14:42 UTC


Attachments (Terms of Use)
lshal output (after hibernation) (deleted)
2008-06-28 20:49 UTC, Johan Vromans
no flags Details

Description Johan Vromans 2008-06-23 12:38:56 UTC
Description of problem:

After a hibernate/resume cycle, NetworkManager starts issuing the following
message every 6 seconds:

NetworkManager: <WARN>  killswitch_getpower_reply(): Error getting killswitch
power: process 14719: arguments to dbus_move_error() were incorrect, assertion
"(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c
line 278. #012 This is normally a bug in some application using the D-Bus library..

Since the process ID is different every time, the messages are not suppressed,
filling the syslog (some 250MB per day!).

Version-Release number of selected component (if applicable):

kernel-tuxonice-devel-2.6.25.6-55_1.cubbi_tuxonice.fc9.i686
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386

How reproducible:

This is a Toshiba Satellite A200-237 notebook. It has a 4965AGN WiFi network card.

After a fresh boot, everything works fine.
After hibernate/resume, NetworkManager starts emitting the messages.
It makes no difference whether the notebook is on WiFi or wired connection.
Switching the RF Killswitch on or off makes no difference.
Not running a session (hence, no nm-applet) makes no difference.
Stopping and restarting NetworkManager makes no difference. The new
NetworkManager instance will immedeately start emitting the same messages.
Unloading the iwl4965 module stops the messages. After reloading the module the
messages appear again.

Additional info:

http://johan.vromans.org/articles/Toshiba-Satellite-A200-237/index.html

Comment 1 Johan Vromans 2008-06-23 12:44:21 UTC
Okay, it's only 5MB per day...

Comment 2 Bradley 2008-06-24 14:15:02 UTC
MeToo. Possibly related to the killswitch not working at all? (bug 449891)

Comment 3 Johan Vromans 2008-06-24 17:25:08 UTC
Possibly. However, my kill switch works, and is correctly detected:
kernel: iwl4965: Radio Frequency Kill Switch is On:
kernel: Kill switch must be turned off for wireless networking to work.


Comment 4 Dan Williams 2008-06-27 15:47:24 UTC
Can somebody give me the lshal output for their killswitch after resume? 
'lshal' and look for the part that references 'killswitch'.

Comment 5 Johan Vromans 2008-06-28 20:49:42 UTC
Created attachment 310517 [details]
lshal output (after hibernation)

Comment 6 Dan Williams 2008-11-02 22:14:42 UTC
Should be fixed in latest NM updates (svn4022 and later)


Note You need to log in before you can comment on or make changes to this bug.