Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452476 - Traceback during sync, when errata has no description.
Summary: Traceback during sync, when errata has no description.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 520
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Sayli Karmarkar
URL:
Whiteboard:
Depends On:
Blocks: 474082
TreeView+ depends on / blocked
 
Reported: 2008-06-23 09:20 UTC by Miroslav Suchý
Modified: 2015-03-23 01:09 UTC (History)
8 users (show)

Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 20:26:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miroslav Suchý 2008-06-23 09:20:02 UTC
Description of problem:
From rhn-satellite@redhat.com:
Hi again and once again, thanks for the tips.

I have been experimenting with the script, and find that for our Lab Satellite
here we get the following traceback for certain channels:


Channel: Red Hat Desktop (v. 3 for x86) Label: rhel-i386-desktop-3
Traceback (most recent call last):
  File "repomd-precache.py", line 28, in ?
    repo.get_repomd_file()
  File "/usr/share/rhn/server/repomd/repository.py", line 326, in get_repomd_file
    self.repository.get_updateinfo_xml_file(),
  File "/usr/share/rhn/server/repomd/repository.py", line 106, in
get_updateinfo_xml_file
    viewobj.write_updateinfo()
  File "/usr/share/rhn/server/repomd/view.py", line 305, in write_updateinfo
    self.fileobj.write('\n'.join(self._get_erratum(erratum)))
  File "/usr/share/rhn/server/repomd/view.py", line 289, in _get_erratum
    output.append("    <description>%s</description>"
TypeError: cannot concatenate 'str' and 'NoneType' objects 

Version-Release number of selected component (if applicable):
520

How reproducible:
the bug is obvious

Steps to Reproduce:
1. sync some channel with errate which has some synopsis and empty description
(or reverse: some description and none synopsis)
2. regenerate repomd cache either by requesting data from it by client or
regenerate using rhnChannel.channel_info API call.
  
Actual results:
Traceback

Expected results:
Works as charm.

Comment 1 Miroslav Suchý 2008-06-23 09:24:37 UTC
Fixed in trunk rev. 174335

Comment 2 Brandon Perkins 2008-07-30 02:59:57 UTC
Removing Bug 452476 depends on bug 452675.

Comment 5 Miroslav Suchý 2009-04-20 07:54:34 UTC
For Sayli:
Yes, you will need some RH channel with null description. It will be hard to get some. Since on hosted none with null description exist. So you will either create one yourself (dunno how) or you will find some old channel dump and import that.
Errata with null description was - for example - the 0day errata we used for release of Proxy 5.2. 
But again, you have to get it from some old dump. Current errata on hosted is fixed.

Comment 6 Sayli Karmarkar 2009-04-27 21:15:52 UTC
Verified. Synced rhel-i386-desktop-3 from old channel dumps and requested data from it by client. No traceback generated.

Comment 7 Brandon Perkins 2009-09-10 20:26:07 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html


Note You need to log in before you can comment on or make changes to this bug.