Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452475 - GtkHtml scrolls message to top whenever embedded animated gif changes
Summary: GtkHtml scrolls message to top whenever embedded animated gif changes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 476194 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 08:17 UTC by Stjepan Gros
Modified: 2009-01-27 15:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-27 15:26:38 UTC


Attachments (Terms of Use)

Description Stjepan Gros 2008-06-23 08:17:36 UTC
Description of problem:

In mails that contain animated gifs it's not possible to scroll message past the
gif. Whenever gif changes evolution positions message on top. This makes it
impossible to read message.

Version-Release number of selected component (if applicable):

2.22.2

How reproducible:

Always

Steps to Reproduce:
1. Open relatively long message that has animated gif embedded (gif has to be
invisible prior to scroll)
2. Try to scroll message past animated gif
  
Actual results:

Whenever animated gif appears in preview pane, the message is automatically
scrolled to top.

Expected results:

Message preview must not automatically scroll.

Additional info:

Comment 1 Milan Crha 2008-12-12 13:20:20 UTC
*** Bug 476194 has been marked as a duplicate of this bug. ***

Comment 2 Milan Crha 2008-12-12 13:22:27 UTC
As far as I heard about this, it does that only with the Caret Mode on (F7 or View->Caret Mode). Just for an easier reproducer, can one of you attach here such simple message for testing, please? Thanks in advance.

Comment 3 Carlos Vassalo 2008-12-12 13:37:05 UTC
I confirm that. With Caret Mode set to off, everything works good. Thank you.

Comment 4 Matthew Barnes 2009-01-27 15:26:38 UTC
Sounds like that solution is sufficient for this report.  I'll close this as WORKSFORME and let upstream deal with Caret Mode's many quirks.


Note You need to log in before you can comment on or make changes to this bug.