Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452468 - Setting of disk-size is lost when clicking button "back"
Summary: Setting of disk-size is lost when clicking button "back"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 453522 (view as bug list)
Depends On:
Blocks: 449772
TreeView+ depends on / blocked
 
Reported: 2008-06-23 07:50 UTC by Petr Sklenar
Modified: 2009-12-14 21:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:20:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0137 normal SHIPPED_LIVE virt-manager enhancement and bug fix update 2009-01-20 16:05:01 UTC

Description Petr Sklenar 2008-06-23 07:50:12 UTC
Description of problem:
Setting of disk-size is lost when clicking button "back"

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. click "New" in virt-manager
2. Forward till "Assigning storage space"
3. Choose "Simple File" and set some value, but not a default, like 5000 MB
4a Click back and forward, there is default value = 4000MB
4b Click forward and back, there is default value = 4000MB

Actual results:
Disk size is changing to default when moving in wizard screens.

Expected results:
There is my value set in "step 4" during changing wizard's screen to back.

Additional info:

Comment 1 Petr Sklenar 2008-06-23 07:51:03 UTC
# rpm -q virt-manager
virt-manager-0.5.3-8.el5


Comment 2 Cole Robinson 2008-06-23 20:19:24 UTC
This is fixed upstream (we'll need two csets for completeness)

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=5e5c99cf3562
http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=523f2f7501c6

I'll pull this in for 5.3

Comment 3 RHEL Product and Program Management 2008-06-23 20:34:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Petr Sklenar 2008-06-25 15:40:45 UTC
hello,
Checkbox "Allocate entire virtual disk now?" is lost too during moving in wizard.
It should be fixed too.


Comment 6 Alexander Todorov 2008-07-09 11:33:55 UTC
*** Bug 453522 has been marked as a duplicate of this bug. ***

Comment 7 Cole Robinson 2008-07-09 15:58:53 UTC
Comment #5, I can't reproduce that on 5.2. Can you give the virt-manager version
and how exactly you reproduce this? Thanks

Comment 8 Alexander Todorov 2008-07-10 06:20:13 UTC
Also can't reproduce comment #5 with virt-manager-0.5.3-8.el5 on 5.2. 
The disk size bug still reproduces though. 

Comment 9 Petr Sklenar 2008-07-10 16:16:45 UTC
I am sorry I made a mistake in that Comment #5. Checkbox "Allocate entire
virtual disk now?" is NOT lost. its OK. Bug is only Comment #0


Comment 10 Cole Robinson 2008-09-15 16:08:02 UTC
Okay, this should be fixed in virt-manager-0.5.3-9.el5. Setting bug to
MODIFIED.

Comment 13 errata-xmlrpc 2009-01-20 21:20:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0137.html


Note You need to log in before you can comment on or make changes to this bug.