Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452451 - php-pecl-apc causing httpd segfaults
Summary: php-pecl-apc causing httpd segfaults
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-apc
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Chabot
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 02:10 UTC by Dennis Jacobfeuerborn
Modified: 2008-07-15 12:21 UTC (History)
0 users

Fixed In Version: 3.0.19-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-15 12:21:53 UTC


Attachments (Terms of Use)
backtrace (deleted)
2008-06-23 02:10 UTC, Dennis Jacobfeuerborn
no flags Details
Spec file patch for 3.0.19 (deleted)
2008-06-29 12:52 UTC, Vaclav "sHINOBI" Misek
no flags Details | Diff

Description Dennis Jacobfeuerborn 2008-06-23 02:10:38 UTC
I have problems with occasional httpd segfaults on my machine which seem to be
caused by php-pecl-apc-3.0.14-3.fc9.i386 according to my investigations. See
attached backtrace for details.

Maybe this is the culprit: http://news.php.net/php.pecl.dev/4951

If it is then an update to a version >=3.0.16 should fix the problem (3.0.19 is
the latest version available on the pecl site).

Comment 1 Dennis Jacobfeuerborn 2008-06-23 02:10:38 UTC
Created attachment 310010 [details]
backtrace

Comment 2 Vaclav "sHINOBI" Misek 2008-06-29 12:51:31 UTC
I hit the same bug and tried to build a 3.0.19 version, updated .spec file patch
attached. It seems that with new version, there are no more segfaults.

Comment 3 Vaclav "sHINOBI" Misek 2008-06-29 12:52:46 UTC
Created attachment 310536 [details]
Spec file patch for 3.0.19

Comment 4 Dennis Jacobfeuerborn 2008-07-02 20:19:18 UTC
Yep, I can confirm that since I installed a rebuilt version with that specfile I
no longer see the segfaults.


Comment 5 Fedora Update System 2008-07-13 10:24:56 UTC
php-pecl-apc-3.0.19-1.fc8 has been submitted as an update for Fedora 8

Comment 6 Fedora Update System 2008-07-13 11:24:38 UTC
php-pecl-apc-3.0.19-1.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-07-15 12:21:49 UTC
php-pecl-apc-3.0.19-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.