Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452446 - bugs while configuring wireless networkoing
Summary: bugs while configuring wireless networkoing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: Branislav Blaškovič
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-23 00:52 UTC by bharatbhai thakkar
Modified: 2014-09-16 00:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In certain cases, when the user dismissed a dialog immediately after it popped up, the system-config-network service could terminate unexpectedly. The service has been modified to verify properly if the dialog has already been dismissed.
Clone Of:
Environment:
Last Closed: 2014-09-16 00:17:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
file is as same as copied (deleted)
2008-06-23 00:52 UTC, bharatbhai thakkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1195 normal SHIPPED_LIVE system-config-network bug fix update 2014-09-16 04:14:20 UTC

Description bharatbhai thakkar 2008-06-23 00:52:24 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

1.I find message on my laptop as it was not working for wireless networking and 
same is sent here with by actual copy of it.
My mail address is bstjudge@yahoo.com. Laptop is from INDIA under e-court 
project with NIC AS I am in CANADA for short visit I am sending this mail from 
another laptop.
2.Message is copied and is as under

Component: system-config-network
Version: 1.3.99
Summary: TB3c0e7198 
GUI_functions.py:466:gui_run_dialog:AttributeError: 'NoneType' object has no 
attribute 'connect'

Traceback (most recent call last):
  File "/usr/bin/system-control-network", line 190, in on_activateButton_clicked
    (ret, msg) = dev.activate()
  File "/usr/share/system-config-network/netconfpkg/NCDevice.py", line 417, in 
activate
    dialog = dialog )
  File "/usr/share/system-config-network/netconfpkg/NC_functions.py", line 575, 
in generic_run_dialog
    dialog = dialog)
  File "/usr/share/system-config-network/netconfpkg/gui/GUI_functions.py", line 
466, in gui_run_dialog
    dlg.connect( "delete-event", __on_Dialog_close )
AttributeError: 'NoneType' object has no attribute 'connect'

Local variables in innermost frame:
xml: <glade.XML object (PyGladeXML) at 0xb7a241bc>
stdin: 0
dlg: None
string: <module 'string' from '/usr/lib/python2.4/string.pyc'>
img: None
title: system-config-network:

Network device activating...
root: /
gtk: <module 'gtk' from '/usr/lib/python2.4/site-packages/gtk-
2.0/gtk/__init__.pyc'>
command: /sbin/ifup
CancelException: netconfpkg.gui.GUI_functions.CancelException
label: Activating network device eth0:kitchener, please wait...
catchfd: (1, 2)
searchPath: 0
argv: ['/sbin/ifup', 'eth0:kitchener', 'up']
closefd: -1
dialog: None
swindow: None
os: <module 'os' from '/usr/lib/python2.4/os.pyc'>
lbl: None
select: <module 'select' from '/usr/lib/python2.4/lib-dynload/selectmodule.so'>
errlabel: Cannot activate network device eth0:kitchener!


3.    I am awaiting solution from your office Please send me the same on 
bstjudge@yahoo.com

  
Actual results:


Expected results:


Additional info:

Comment 1 bharatbhai thakkar 2008-06-23 00:52:24 UTC
Created attachment 310008 [details]
file is as same as copied

Comment 2 Radek Bíba 2009-05-11 10:38:57 UTC
Is this a duplicate of bug 291461 and therefore fixed as of RHEL 5.3?

Comment 3 Harald Hoyer 2009-05-11 11:39:01 UTC
This is another bug, where the user pressed "Cancel", while waiting for the interface to come up.

Comment 6 Branislav Blaškovič 2014-06-03 12:33:03 UTC
Can not longer reproduce this with system-config-network-1.3.99.23-1.el5.

dlg is now checked for NoneType so error dialog with error message should show up.

Comment 8 errata-xmlrpc 2014-09-16 00:17:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1195.html


Note You need to log in before you can comment on or make changes to this bug.