Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452441 - Unusual RAID configurations not supported
Summary: Unusual RAID configurations not supported
Keywords:
Status: CLOSED DUPLICATE of bug 105598
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 23:45 UTC by Michal Ruzicka
Modified: 2008-06-23 11:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 11:30:00 UTC


Attachments (Terms of Use)
Patch to allow creating / installing to a single device RAID1 array (deleted)
2008-06-22 23:45 UTC, Michal Ruzicka
no flags Details | Diff

Description Michal Ruzicka 2008-06-22 23:45:38 UTC
Description of problem:
It is not possible to create (and install) into a software (md) RAID1 array
consisting of one device only. For example something like this:

# cat /proc/mdstat
...
md2 : active raid1 sdb3[0]
      155131584 blocks [1/1] [U]
...

# mdadm --verbose --examine --scan
...
ARRAY /dev/md2 level=raid1 num-devices=1 UUID=d14dced6:c8d333d3:bf1ade60:6e302053
   devices=/dev/sdb3
...


The same is probably true for RAID0 arrays as well.

I run into this problem when reinstalling my Fedora 7 box to Fedora 9:
- I had Fedora 7 installed on a RAID1 array consisting of two devices (usual
scenario)
- before the reinstall I had removed one of the devices from the RAID1 array
thus creating a 'degenerated' yet legal RAID1 configuration and freeing the
removed device for a fresh install
- I hoped to create similar 'degenerated' RAID1 array on the freed device,
perform a fresh install to this array, then migrate some data from the original
array to the new one and finally add the original device as a second device to
the new array (thus having the usual configuration again)

Unfortunately anaconda does not allow creating (neither installing to) RAID1
arrays consisting of one device only.

Presumably this just to prevent a user from creating such 'degenerated'
configuration by mistake as such a configuration poses no problem for the later
stages of the installation process.
At least it worked for me after I had relaxed the checks (see the attached
patch) performed by anaconda for the number of devices in RAID arrays.

I think that a user should be allowed to create any RAID configuration he/she
sees fit. Perhaps with some warnings in case the configuration is similarly
'degenerated' as mine.


Version-Release number of selected component (if applicable):
11.4.0.82-1

How reproducible:
Always

Steps to Reproduce:
1. start Fedora installation process 
2. get to the custom disk setup step of the installation
3. create a single software RAID partition
4. try to create a RAID array
  
Actual results:
It is not possible to create the RAID array, at least two software RAID
partitions are required.

Expected results:
It should be possible to create a RAID0 or RAID1 array on one software RAID
partition only. Perhaps after acknowledging a warning that such a configuration
does not possess the properties (fault tolerance, performance) that might be
expected from a RAID array of the specified level.

Additional info:
The attached patch is barely more than the minimal amount of changes need to
make graphical mode anaconda installer to create and install into a RAID1 array
consisting of a single RAID partition only. Specifically it does not touch the
text mode installer nor does introduce the kind of warnings mentioned earlier.

Comment 1 Michal Ruzicka 2008-06-22 23:45:38 UTC
Created attachment 310007 [details]
Patch to allow creating / installing to a single device RAID1 array

Comment 2 Chris Lumens 2008-06-23 11:30:00 UTC

*** This bug has been marked as a duplicate of 105598 ***


Note You need to log in before you can comment on or make changes to this bug.