Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452436 - "RuntimeError: Error running reiserfstune" after detailed disk layout dialog
Summary: "RuntimeError: Error running reiserfstune" after detailed disk layout dialog
Keywords:
Status: CLOSED DUPLICATE of bug 446513
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 22:46 UTC by Petr Machata
Modified: 2015-05-05 01:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 18:10:14 UTC


Attachments (Terms of Use)
First fail log. (deleted)
2008-06-22 22:46 UTC, Petr Machata
no flags Details
Second fail log. (deleted)
2008-06-22 22:46 UTC, Petr Machata
no flags Details

Description Petr Machata 2008-06-22 22:46:09 UTC
I was installing F 9 from live CD to oldish i386 athlon machine.

My situation is as follows. I have two disks, sda and sdb.  sdb is "new" disk, I
have had sda before that.  For that reason, sda contains several partitions that
used to serve purposes of /boot, swap, and /.  Nowadays I use sda as /boot, swap
and /home, while having / on the "new" disk, sdb.  /home partition is pretty
aged reiserfs, the rest are ext3 partitions (and swap).

What I did when presented with disk layout dialog was that I requested detailed
view (sorry, forgot how is it called exactly).  There I assigned sda1, sda2 and
sda3 respectively to /boot, swap and /home.   I allowed reformatting of sda1,
but not of sda3 (obviously).  It bothers me a bit that anaconda tried to run
reiserfstune even though I asked it not to mess with that partition, but there
could have been legitimate reasons for that.

I assigned sdb solely to / (which is to say that there was single partition sdb1
on that disk), and asked anaconda to reformat it.

Then I hit next, and anaconda thrown the exception.  I tried the whole process
three times total, each time reducing the amount of my tinkering.  In the end I
just didn't use detailed view at all, and just ticked out sda and let anaconda
do its magic.  This worked.

I will attach the two fail logs that anaconda spewed.

Comment 1 Petr Machata 2008-06-22 22:46:09 UTC
Created attachment 310003 [details]
First fail log.

Comment 2 Petr Machata 2008-06-22 22:46:45 UTC
Created attachment 310004 [details]
Second fail log.

Comment 3 Chris Lumens 2008-06-23 18:10:14 UTC

*** This bug has been marked as a duplicate of 446513 ***


Note You need to log in before you can comment on or make changes to this bug.