Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452426 - /sbin/kpartx.static is a symlink to its dynamic counterpart
Summary: /sbin/kpartx.static is a symlink to its dynamic counterpart
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ben Marzinski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 20:01 UTC by Jason Bradley Nance
Modified: 2008-06-24 14:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 14:45:04 UTC


Attachments (Terms of Use)

Description Jason Bradley Nance 2008-06-22 20:01:12 UTC
Description of problem:
/sbin/kpartx.static is a symlink to its dynamic counterpart instead of
an actual statical version of the executable.


Version-Release number of selected component (if applicable):
kpartx-0.4.7-15.fc9.i386


Additional info:
To be honest, I'm not sure if this is actually a bug or not.  It just seems
wrong that the *.static link points to dynamic version.  I discovered this
while researching bug 452423.

Opening against device-mapper since there isn't a kpartx component in bugzilla.

Comment 1 Ben Marzinski 2008-06-24 14:45:04 UTC
Nope. This isn't very pretty, but it's not a bug.  It's a holdover from before
we could execute dynamically linked binaries in early bootup. It's no longer
necessary to have a statically linked binary, and in fact, libdevmapper no
longer exists in as a statically linkable library. However, mkinitrd still
references the static versions of these commands, so they need to exist until
all the references go away.


Note You need to log in before you can comment on or make changes to this bug.