Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452422 - qemu: could not open disk image
Summary: qemu: could not open disk image
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 18:44 UTC by Dalibor Karlović
Modified: 2008-07-24 08:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 08:13:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 447808 None CLOSED QEMU unable to read qcow format (qemu 0.9.1) 2018-05-14 06:49:38 UTC

Description Dalibor Karlović 2008-06-22 18:44:48 UTC
Description of problem:
when I try to run some new downloaded ISOs with virt-manager, it says:

Unable to complete install: 'virDomainCreateLinux() failed internal error QEMU
quit during console startup
qemu: could not open disk image
/mnt/storage/software/linux/ISOs/openSUSE-11.0-KDE4-LiveCD-i386.iso

Details:

Unable to complete install '<class 'libvirt.libvirtError'>
virDomainCreateLinux() failed internal error QEMU quit during console startup
qemu: could not open disk image
/mnt/storage/software/linux/ISOs/openSUSE-11.0-KDE4-LiveCD-i386.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 651, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 845, in
start_install
    return self._do_install(consolecb, meter)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 866, in
_do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 833, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed internal error QEMU quit during
console startup
qemu: could not open disk image
/mnt/storage/software/linux/ISOs/openSUSE-11.0-KDE4-LiveCD-i386.iso

Version-Release number of selected component (if applicable):

[dado@amelie ~]$ rpm -qi virt-manager qemu | grep -E "(Version|Release)"
Version     : 0.5.4                             Vendor: Fedora Project
Release     : 4.fc9                         Build Date: Fri 09 May 2008 08:21:13
PM CEST
Version     : 0.9.1                             Vendor: Fedora Project
Release     : 5.fc9                         Build Date: Mon 24 Mar 2008 10:32:08
PM CET

How reproducible:
Download a Live CD ISO, start virt-manager, connect to qemu and create the new VM.
  
Actual results:
The above error.

Expected results:
Created and running VM.

Additional info:
It could be related to https://bugzilla.redhat.com/show_bug.cgi?id=447808 but I
can't be sure. FWIW, this works on F8.

Comment 1 Nils Philippsen 2008-07-04 09:24:24 UTC
Same here. Is there any additional info that is needed to get this fixed?

Comment 2 Daniel Berrange 2008-07-23 15:20:25 UTC
All disk images must be in /var/lib/libvirt/images/ to comply with SELinux
policy. Failing that you need to ensure the alternative directory you are using
is labelled with 'virt_image_t'.


Comment 3 Nils Philippsen 2008-07-23 16:43:21 UTC
Thanks Dan, that works for me. As far as I'm concerned, the bug can be closed.

Dalibor, can you check if what Dan described in comment #2 works for you?

Comment 4 Dalibor Karlović 2008-07-23 17:14:15 UTC
Not really, I've already downgraded to F8, but I'll take your word on it that it
works. :) You can close this.

Comment 5 Nils Philippsen 2008-07-24 08:13:03 UTC
Thanks, closing.


Note You need to log in before you can comment on or make changes to this bug.