Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452419 - NM doesn't connect automatically to a DSL connection
Summary: NM doesn't connect automatically to a DSL connection
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 10
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 17:58 UTC by Igor Pires Soares
Modified: 2009-02-20 14:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-20 14:56:32 UTC


Attachments (Terms of Use)

Description Igor Pires Soares 2008-06-22 17:58:04 UTC
Description of problem:
Can't connect automatically to a DSL connection created with NetworkManager and
when try to connect manually it asks for the password. If I have marked "Connect
automatically" and typed my password in the create connection dialog it should
not ask for the password every time I try to connect.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.4.svn3675.fc9.i386
NetworkManager-gnome-0.7.0-0.9.4.svn3675.fc9.i386

Steps to Reproduce:
1. Create a DSL connection (inserting username, service and password)
2. Mark "Connect automatically"
3. Logout or restart computer
4. NM doesn't pickup the DSL connection, it chooses an "auto eth0" instead.
5. Click in NM applet and select the DSL connection, it will ask for the
password, but I have already set it while adding the connection.
  
Actual results:
Does not connect automatically: pick another connection and when select the DSL
one manually asks for password.

Expected results:
Should connect automatically picking the DSL connection by default and don't ask
for password.

Comment 1 Mathieu Bridon 2008-09-06 22:16:55 UTC
About the password, it is stored in Gnome-Keyring, so it's the password for unlocking Gnome-Keyring that is asked. If you correctly set this up, password will not be asked.

About the DSL connection problem, I have the same problem here.

In fact, there could be 2 ways of solving this:
1. when user manually specifies a connection to auto-connect, this should override the system connections auto-connect property.
2. System connections should be editable. In fact they are in upstream NM, but a patch is applied in the Fedora package to disable it (I was told on IRC that the way Fedora handles NM confs does not permit for this feature, which is why it was disabled).

Comment 2 Mathieu Bridon 2008-09-07 12:26:00 UTC
It looks like the editing of system connections is fixed in Rawhide with NetworkManager-0.7.0-0.11.svn3830.fc10.x86_64

Looks like this bug is no more :)

Comment 3 Igor Pires Soares 2008-12-12 20:13:07 UTC
Great, the connection issue is really fixed in Fedora 10.

But I still don't know how to solve the gnome-keyring problem. It is weird because NetworkManager just asks the keyring password if I setup the gdm auto login.

Comment 4 Dan Williams 2009-02-20 14:56:32 UTC
Gnome keyring is another issue; I think there are some filed about it.  If you could add any issues you have to the bug that matches your issue most closely, that would be great.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.