Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452400 - mplayer: pcm_pulse.c:274: pulse_write: Assertion `pcm->last_size >= (size * pcm->frame_size)' failed
Summary: mplayer: pcm_pulse.c:274: pulse_write: Assertion `pcm->last_size >= (size * p...
Keywords:
Status: CLOSED DUPLICATE of bug 453908
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 05:11 UTC by Shawn Starr
Modified: 2008-07-25 10:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-25 10:30:15 UTC


Attachments (Terms of Use)

Description Shawn Starr 2008-06-22 05:11:03 UTC
Description of problem:
When using mplayer which is not part of Fedora, pulseaudio throws an assertion

mplayer: pcm_pulse.c:274: pulse_write: Assertion `pcm->last_size >= (size *
pcm->frame_size)' failed.

Version-Release number of selected component (if applicable):
PulseAudio 0.9.11-0.4
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386


How reproducible:
100% of time

Steps to Reproduce:
1. run mplayer (or vlc) with an audio file (an mp3)
2. observe assertion failure
  
Actual results:
app crashes

Expected results:
sound should be heard via PulseAudio.

Additional info:

PulseAudio is being started with following command (by KDE 4.1/trunk)

/usr/bin/pulseaudio --daemonize=yes -Lmodule-native-protocol-fd fd=20
--log-target=syslog --exit-idle-time=5

Comment 1 Valdis Kletnieks 2008-07-06 07:54:11 UTC
This looks like a dup of bug #433908, or that one is a dup of this one - in any
case, mplayer is hitting the same assert I was...

Comment 2 Erik van Pienbroek 2008-07-11 12:49:52 UTC
(In reply to comment #1)
> This looks like a dup of bug #433908, or that one is a dup of this one - in any
> case, mplayer is hitting the same assert I was...

I think you've linked to the wrong bugreport..

Anyway, I'm also encountering this assertion error on a fully updated rawhide
system. However, I'm not encountering it with mplayer, but with artsd (kde3)
which gets started when using k3b


Comment 3 Valdis Kletnieks 2008-07-11 15:24:54 UTC
Gaak. You're right. Typo - it's a dup of bug #453908, not 433...

Comment 4 Hans de Goede 2008-07-25 10:30:15 UTC
Hi,

I'm seeing this too and I agree this is a dup of bug 453908, closing as such.
I'll send Lennert a personal mail about this as he doesn't watch bugzilla too
closely.


*** This bug has been marked as a duplicate of 453908 ***


Note You need to log in before you can comment on or make changes to this bug.