Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452397 - git config creates duplicate sections in .git/config
Summary: git config creates duplicate sections in .git/config
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: git
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Wright
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 03:01 UTC by Hans Ulrich Niedermann
Modified: 2013-01-10 10:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-19 11:31:08 UTC


Attachments (Terms of Use)

Description Hans Ulrich Niedermann 2008-06-22 03:01:00 UTC
Description of problem:

  A sequence of
     git config x.y v1
     git config --unset x.y
     git config x.y v2
  leaves two [x] sections in .git/config.

Version-Release number of selected component (if applicable):

  git-1.5.5.1-1.fc9.i386

How reproducible:

  100%

Steps to Reproduce:
   mkdir test.git
   cd test.git
   git init
   sed -n '/m4rker/,$p' .git/config
   git config m4rker.foo v1
   sed -n '/m4rker/,$p' .git/config
   git config --unset m4rker.foo
   sed -n '/m4rker/,$p' .git/config
   git config m4rker.foo v2
   sed -n '/m4rker/,$p' .git/config
  
Actual results:

   [m4rker]
   [m4rker]
           foo = v2

Expected results:

   [m4rker]
           foo = v2

Additional info:

Comment 1 Todd Zullinger 2009-01-12 03:23:17 UTC
I don't know that upstream guarantees that "git config" will create pretty config files.  Do the extra markers actually cause harm or are they just unsightly?

Comment 2 Todd Zullinger 2009-02-19 04:39:03 UTC
Hans, can you confirm whether you've found any problem caused by the extra markers in the config file, other than their redundancy?  If not, I'd be inclined to close this as NOTABUG.

Comment 3 Hans Ulrich Niedermann 2009-02-19 11:31:08 UTC
Only wetware problems when editing .git/config.

Closing as NOTABUG, then.


Note You need to log in before you can comment on or make changes to this bug.