Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452394 - Audio broken on big endian archs
Summary: Audio broken on big endian archs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: crack-attack
Version: 9
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-22 02:00 UTC by Ian Chapman
Modified: 2008-06-26 08:33 UTC (History)
0 users

Fixed In Version: 1.1.14-14.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 08:30:16 UTC


Attachments (Terms of Use)

Description Ian Chapman 2008-06-22 02:00:07 UTC
Description of problem:

Audio is broken on big endian archs, eg ppc and ppc32. The music sounds like
static noise with a rough beat.


Version-Release number of selected component (if applicable):
crack-attack-1.1.14-13.fc9.ppc

How reproducible:

Run crack-attack

Steps to Reproduce:
1. Run crack-attack
2.
3.
  
Actual results:

Sound is awful.

Expected results:

Sound should be nice! :-)


Additional info:

The culprit appears to be the single use of 'AUDIO_S16' in
'crack-attack-1.1.14/src/Sound.cxx' which is LSB. Replacing it with
'AUDIO_S16SYS' uses the systems native byte order and fixes it on my ppc systems
without breaking i386.

Comment 1 Fedora Update System 2008-06-24 14:08:50 UTC
crack-attack-1.1.14-14.fc8 has been submitted as an update for Fedora 8

Comment 2 Fedora Update System 2008-06-24 14:09:56 UTC
crack-attack-1.1.14-14.fc9 has been submitted as an update for Fedora 9

Comment 3 Hans de Goede 2008-06-24 14:13:34 UTC
Thanks for reporting2 this and thanks for the fix.

An update with this fixed is on its way to updates for F-8 and F-9, rawhide
currently can't be build due to broken deps, I will build it as soon as rawhide
is sane again.


Comment 4 Fedora Update System 2008-06-26 08:30:14 UTC
crack-attack-1.1.14-14.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2008-06-26 08:33:34 UTC
crack-attack-1.1.14-14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.