Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452380 - rotated text is displayed incorrectly
Summary: rotated text is displayed incorrectly
Keywords:
Status: CLOSED DUPLICATE of bug 451485
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 17:32 UTC by Joe Smith
Modified: 2008-06-22 20:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-22 20:33:15 UTC


Attachments (Terms of Use)
Sample ODF text document (deleted)
2008-06-21 17:32 UTC, Joe Smith
no flags Details
Screenshot showing incorrect text display (deleted)
2008-06-21 17:34 UTC, Joe Smith
no flags Details

Description Joe Smith 2008-06-21 17:32:43 UTC
Description of problem:
Text in vertical orientation is displayed incorrectly, with parts of the text
rotated and other parts normal.

Version-Release number of selected component (if applicable):
openoffice.org-writer-2.4.1-17.3.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Open the attached document
2. Rotate /both/ text boxes to 90 degrees: Rt-click > Position and Size >
Rotation > Rotation Angle = 90
3. One text box will rotate correctly, one incorrectly, as shown in the attached
screenshot.
  
Actual results:
Jumbled text display

Expected results:
Correctly rotated text

Additional info:
The display is incorrect in File > Page Preview as well.
Printing or export to PDF shows the correct rendering.

Same problem affects rotated text in tables (also shown in screenshot).

The order of the effect is not consistent: it seems that only one rotated item
will work and others all fail, but it's not always the first item. I don't see a
clear pattern in the order.

OO.org-packaged 2.4.1 on the same system does not have this problem.

Comment 1 Joe Smith 2008-06-21 17:32:43 UTC
Created attachment 309977 [details]
Sample ODF text document

Comment 2 Joe Smith 2008-06-21 17:34:02 UTC
Created attachment 309978 [details]
Screenshot showing incorrect text display

Comment 3 Caolan McNamara 2008-06-22 20:33:15 UTC

*** This bug has been marked as a duplicate of 451485 ***


Note You need to log in before you can comment on or make changes to this bug.