Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452373 - kernels after 2.6.24 broke intel 82801h sound
Summary: kernels after 2.6.24 broke intel 82801h sound
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: ia64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 17:04 UTC by Vince Herried
Modified: 2009-01-09 07:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-09 07:50:19 UTC


Attachments (Terms of Use)

Description Vince Herried 2008-06-21 17:04:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
Kernel kernel-2.6.24.7-92.fc8 still works.
the sound card tool detects sound but nothing is played


Version-Release number of selected component (if applicable):
kernel-2.6.25.6-27.fc8

How reproducible:
Always


Steps to Reproduce:
1.  boot
2.  play a sound any sound
3.

Actual Results:
no sound

Expected Results:
music


Additional info:
This is on a Dell Xps M1330

------- System Config Soundcard Log --------
Sat Jun 21 12:20:51 EDT 2008

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 b
it Little Endian, Rate 44100 Hz, Stereo
ProbeCards, method =  hal
--------- Card 0 --------
Active 1
Vendor: Intel Corporation
Model: 82801H (ICH8 Family) HD Audio Controller
Driver: snd-hda-intel

Volume: 75
Devices:
[[0, ' STAC92xx Analog ']]
Test device 0

Comment 1 Mary Ellen Foster 2008-06-21 22:54:49 UTC
Actually -- based on another machine with the same sound card that's
experiencing similar symptoms -- I think this is actually the mixer not properly
saving and restoring its state, so it comes up with the "master" control all the
way to zero and muted, and PCM and front both low (but not muted). Manually
running alsactl store before shutting down and alsactl restore on restart works
fine.

This all started with the kernel 2.6.25 update -- everything was fine with the
previous 2.6.24 kernels.

Comment 2 Vince Herried 2008-06-22 13:49:54 UTC
well, the alsactl as suggested didn't do the trick, but woke me up...
I fired up the mixer and unmuted and re-set the levels.
I now now know how to save the alsa parms which I didn't know b4.

I'm sorry I didn't spend more time trying to fix it b4 turning in this problem.

Tnx for the very quick response.

Vince


Comment 3 Mary Ellen Foster 2008-06-22 14:39:41 UTC
Have you tried rebooting yet? In my experience, if you restart it'll come up
with all the controls down again, and that's definitely a new bug.

Comment 4 Mary Ellen Foster 2008-06-23 19:51:52 UTC
Reopening because changing the mixer settings doesn't seem to persist across
reboots.

Comment 5 Vince Herried 2008-06-23 21:00:49 UTC
well, it works for me.  After bringing up 2.6.25.6-27.fc8
then running the kdemixer, I ran as a user  sudo /sbin/alsactl store
and all seems ok,  I"ve rebooted several times since and the
sound comes up just fine.

So for me the problem is resolved. Let me know if I can provide
any additional information that will help.


Now if I can get a fix for the
suspend resume which this  kernel also broke.....

V



Comment 6 Alex Butcher 2008-07-19 18:09:10 UTC
As per 448662

Installing kernel 2.6.25.10-47.fc8 with
alsa-kmdl-2.6.25.10-47.fc8-1.0.17-68.fc8.i686.rpm from atrpms.net brought back
sound on my Toshiba Satellite 3000-214. This machine has

00:1f.5 Multimedia audio controller: Intel Corporation 82801CA/CAM AC'97 Audio
Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801CA/CAM AC'97 Modem Controller (rev 01)

I think it's something to do with mixer changes in ALSA 1.0.16 that got included
in 2.6.25. 2.6.24.4-64 worked fine, but .25.6-27, .25.9-40 and .25.10-47 were
all problematic out of the box.

Comment 7 Stephen Rowles 2008-07-21 10:36:42 UTC
As per comment #4, persisting of mixer options does not occur during reboot.

Shutdown occurs OK, including the console output saving sound using salsa -s
However this does not save the sound settings. Each reboot I have to open the
alsamixer -c0 and configure my sound settings again before I can hear anything
(specifically it does not remember the settings for "Front" (restores to muted
despite being un-muted) and "PCM" or "Master" volume levels are not correctly
restored.

System details:

2.6.25.10-47.fc8 #1 SMP Mon Jul 7 18:39:51 EDT 2008 i686 i686 i386 GNU/Linux

$ rpm -qa |grep -i alsa
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-lib-devel-1.0.16-3.fc8
alsa-lib-1.0.16-3.fc8
alsa-utils-1.0.16-3.fc8
alsamixergui-0.9.0-0.3.rc1.fc8.2
alsa-tools-1.0.15-5.fc8

$ cat modprobe.conf
alias eth0 e1000e
options snd cards_limit=8
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7


Comment 8 Bug Zapper 2008-11-26 10:54:27 UTC
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Bug Zapper 2009-01-09 07:50:19 UTC
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.