Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452360 - Enabling European wireless channels makes iwl4965 behave erratically
Summary: Enabling European wireless channels makes iwl4965 behave erratically
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 12:01 UTC by James Ettle
Modified: 2008-06-25 18:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-25 18:11:03 UTC


Attachments (Terms of Use)
dmesg output with ieee80211_regdom=64 option. (deleted)
2008-06-21 12:01 UTC, James Ettle
no flags Details
dmesg from kernel 2.6.25.8-35.fc8 using ieee80211_regdom="EU" (deleted)
2008-06-25 10:55 UTC, James Ettle
no flags Details

Description James Ettle 2008-06-21 12:01:32 UTC
Description of problem:
Putting the line

    options cfg80211 ieee80211_regdom=64

in /etc/modprobe.conf to enable channels 12 and 13 (used by some APs in Europe)
results in erratic behaviour from iwl4965. The system becomes very sluggish
every few seconds.

Version-Release number of selected component (if applicable):
kernel-2.6.24.7-92.fc8
iwl4965-firmware-4.44.1.20-1

How reproducible:
Always.

Steps to Reproduce:
1. Ensure cfg80211 is loaded with ieee80211_regdom=64.
2. Reload iwl4965, iwlcore, mac80211 and cfg80211.

Actual results:
Very sluggish system, multiple ucode errors seen in dmesg (attached).

Expected results:
Euro channel access points detected and used.

Comment 1 James Ettle 2008-06-21 12:01:32 UTC
Created attachment 309965 [details]
dmesg output with ieee80211_regdom=64 option.

Comment 2 John W. Linville 2008-06-24 13:21:01 UTC
Hmmm...well, I think there is some confusion here.  The line in
/etc/modprobe.conf should either be

   options mac80211 ieee80211_regdom=64

for older kernels or it should be

   options cfg80211 ieee80211_regdom="JP"

for newer kernels.  In either case, the dmesg output in comment 1 looks more
like a driver/firmware interaction problem to me.  I would recommend changing 64
to "JP" and using a newer kernel:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52605

Does this improve things for you?

Comment 3 James Ettle 2008-06-25 10:53:48 UTC
OK, I didn't do *exactly* what you asked, I tried kernel-2.6.25.8-35.fc8 from
Koji and passed ieee80211_regdom="EU" (a guess, not wishing to upset the GPO
;)). This produced basically the same result from the desktop perspective:
sluggishness every few seconds. It also wouldn't associate. A dmesg is attached.

[Of course, if kernel-2.6.25.6-27.fc8 somehow contains newer code I'll gladly
try that version.]

Comment 4 James Ettle 2008-06-25 10:55:16 UTC
Created attachment 310251 [details]
dmesg from kernel 2.6.25.8-35.fc8 using ieee80211_regdom="EU"

Note that this includes a stack dump from when I tried suspend/resume (see bug
#437677).

Comment 5 James Ettle 2008-06-25 11:01:22 UTC
John, re Comment #2: I've done a quick search on the IWL Bugzilla and nothing
concrete on this has turned up. Do you want me to try enabling ucode debugging
and report it to them?

Comment 6 John W. Linville 2008-06-25 12:46:50 UTC
Currently only rawhide kernels have support for "EU", so you probably want to
try "JP" for now.  As for the ucode debugging, if you are willing to do that it
will probably be very helpful...thanks!

Comment 7 James Ettle 2008-06-25 18:11:03 UTC
OK, you were right... I tried kernel-2.6.25.9-37.fc8 with ieee80211_regdom="JP"
and it appeared to behave. So I've no idea what EU was doing... closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.