Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452355 - "attempted DOS system call" while installing fedora 9 under KVM
Summary: "attempted DOS system call" while installing fedora 9 under KVM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 454359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 09:43 UTC by Andy Burns
Modified: 2008-07-18 08:06 UTC (History)
7 users (show)

Fixed In Version: 0.4.4-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-18 08:06:25 UTC


Attachments (Terms of Use)
Screenshot of issue. (deleted)
2008-07-08 02:54 UTC, Jonathan Steffan
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 220463 None None None Never

Description Andy Burns 2008-06-21 09:43:23 UTC
Description of problem:

When installing fedora 9 64bit under KVM, the VM is created and the console
opens, and loads from the DVD, but at the boot: prompt the message "attempted
DOS system call" occurs.

If I select QEMU instead of KVM as the hypervisor, the installation does
continue past the boot: prompt.

Version-Release number of selected component (if applicable):

libvirt.x86_64                           0.4.3-1.fc10           installed
libvirt-python.x86_64                    0.4.3-1.fc10           installed
python-virtinst.noarch                   0.300.3-7.fc9          installed
virt-manager.x86_64                      0.5.4-4.fc9            installed

How reproducible:
100%

Steps to Reproduce:
1. create new VM
2. installation source /dev/sr0

Additional info:

N.B I had to install libvirt 0.4.3 from rawhide to work around problem with 

libvirtError: virDomainCreateLinux() failed internal error Timed out while
reading monitor startup output

Comment 1 Jonathan Steffan 2008-07-08 02:54:15 UTC
Created attachment 311221 [details]
Screenshot of issue.

Comment 2 Jonathan Steffan 2008-07-08 02:55:47 UTC
/usr/bin/qemu-kvm -S -M pc -m 512 -smp 1 -name f9testlvm -monitor pty -boot c
-drive file=/home/jon/f9testlvm.img,if=ide,index=0,boot=on -drive
file=/home/jon/Downloads/Fedora-9-x86_64-netinst.iso,if=ide,media=cdrom,index=2
-net nic,macaddr=00:16:3e:2e:7b:73,vlan=0 -net
tap,fd=13,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc
127.0.0.1:0 -k en-us

Comment 3 Martin Poole 2008-07-08 08:23:30 UTC
Seen on f9 32bit.

Fails with libvirt-0.4.4-1.fc9.i386.rpm  libvirt-python-0.4.4-1.fc9.i386.rpm

Reverting to libvirt-0.4.2-3.fc9.i386.rpm  libvirt-python-0.4.2-3.fc9.i386.rpm 
removes the problem



Comment 4 Daniel Berrange 2008-07-08 08:26:30 UTC
This is a KVM bug when using the -drive parameter

The following two commands should be identical:

# qemu-kvm -cdrom /home/berrange/boot.iso -boot d -m 500

# qemu-kvm -drive
file=/home/berrange/boot.iso,if=ide,media=cdrom,index=2,boot=on -m 500

But the 2nd fails with 'Attempted DOS system call'. New libvirt uses the -drive
argument, hence why you see it the problem with newer libvirt. 

Comment 5 Daniel Berrange 2008-07-08 09:34:45 UTC
Upstream thread shows that boot=on doesn't work reliably with CDROMs

http://thread.gmane.org/gmane.comp.emulators.kvm.devel/19242

Comment 6 Daniel Berrange 2008-07-08 11:51:15 UTC
Please try using this libvirt scratch build and tell me if CDROM booting works

http://koji.fedoraproject.org/koji/taskinfo?taskID=702183

Comment 7 Daniel Berrange 2008-07-08 11:52:35 UTC
Oh, don't forget to do 'service libvirtd restart' after installing the scratch
RPM to make sure it uses the new code. NB this will terminate all active guests,
so you might want to shut them down cleanly before this.

Comment 8 Martin Poole 2008-07-08 12:05:28 UTC
Test packages seem to allow a CD/DVD boot.


Comment 9 Fedora Update System 2008-07-08 15:45:23 UTC
libvirt-0.4.4-2.fc9 has been submitted as an update for Fedora 9

Comment 10 Andy Burns 2008-07-08 20:08:31 UTC
(In reply to comment #6)

> Please try using this libvirt scratch build and tell me if CDROM booting works

This version of libvirt failed for me, though not with the "DOS system call" error.

Previously when I used the latest libvirt for f9, I got the error

"libvirtError: virDomainCreateLinux() failed internal error Timed out while
reading monitor startup output"

I was able to install libvirt.0.4.3-1.fc10 to work around this, after which I
discovered the "DOS system call" error

Now I have installed libvirt-0.4.4-2.fc9 I one again get the 

"libvirtError: virDomainCreateLinux() failed internal error Timed out while
reading monitor startup output"

error, so it doesn't get far enough to attempt to boot from CD.

If I remember correctly the fix in libvirt.0.4.3-1.fc10 was related to something
overwriting file descriptors?



Comment 11 Cole Robinson 2008-07-08 20:29:39 UTC
Is there a logfile at /var/log/libvirt/qemu/guestname.log?

Comment 12 Daniel Berrange 2008-07-08 20:33:44 UTC
One bug per ticket please. If you have another problem besides the 'attempted
DOS system call' issue we've already addressed here, please open a new BZ

Comment 13 Andy Burns 2008-07-08 20:43:52 UTC
(In reply to comment #12)

> One bug per ticket please.

Yes I will open a new ticket, the reason I hadn't opened one previously was
because I was hoping that once libvirt-0.4.3-x or later was available for f9, it
would include the fix I knew was already in rawhide ...





Comment 14 Daniel Berrange 2008-07-09 09:48:16 UTC
*** Bug 454359 has been marked as a duplicate of this bug. ***

Comment 15 Andrew Overholt 2008-07-16 15:28:15 UTC
I'm still seeing this on x86_64 F9.  The curious thing is that the
bodhi-generated comment (#9) mentions a version different than what I have and
what is referenced in Dan's koji link:

$ rpm -q libvirt
libvirt-0.4.4-1.fc9.x86_64

Comment 16 Chris Lalancette 2008-07-17 09:46:22 UTC
Right, this is fixed in libvirt-0.4.4-2.fc9.  Most likely whatever mirror you
are using doesn't yet have this in updates or updates-testing (I can't remember
at the moment where it is).  It might be best to point directly at the main
fedora site for this update, and then switch back to your local mirror.

Chris Lalancette

Comment 17 Andrew Overholt 2008-07-17 13:54:38 UTC
I don't think your update is in update or updates-testing but I installed
0.4.4-2 straight from koji and it now works.  Thanks.

Comment 18 Fedora Update System 2008-07-18 08:06:23 UTC
libvirt-0.4.4-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.