Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452341 - moodle package does not require php but should
Summary: moodle package does not require php but should
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: moodle
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 01:19 UTC by Brad Smith
Modified: 2008-07-04 03:41 UTC (History)
0 users

Fixed In Version: 1.9.1-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-04 03:41:21 UTC


Attachments (Terms of Use)

Description Brad Smith 2008-06-21 01:19:32 UTC
Description of problem:
Moodle is a php app, but the package does not require php, so it is possible to
install moodle on a system that is incapable of running it. It requires php-gd
and php-mysql, which only pull in php-common, but not on the php package its self. 

Version-Release number of selected component (if applicable):
1.9-1

How reproducible:
always

Steps to Reproduce:
1. install moodle on a system w/o php
2. try to access moodle
3. get a 403 because there's no index.html (there is index.php instead)

Comment 1 Gwyn Ciesla 2008-06-23 14:35:48 UTC
I see this on 1.9.1-1 as well.  Fixing. . .

Comment 2 Fedora Update System 2008-06-23 16:31:32 UTC
moodle-1.9.1-2.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-06-25 02:51:25 UTC
moodle-1.9.1-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update moodle'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5654

Comment 4 Fedora Update System 2008-07-04 03:41:19 UTC
moodle-1.9.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.