Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452338 - Bug / brain-o in %pre rpm script
Summary: Bug / brain-o in %pre rpm script
Keywords:
Status: CLOSED DUPLICATE of bug 442384
Alias: None
Product: Fedora
Classification: Fedora
Component: crossfire
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Wart
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-21 01:07 UTC by Michael Fleming
Modified: 2008-06-23 16:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 16:06:43 UTC


Attachments (Terms of Use)

Description Michael Fleming 2008-06-21 01:07:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
1.10-3.fc8

How reproducible:
Always, provided.

Steps to Reproduce:
1. "yum install crossfire" where there is no existing "crossfire" user on server.
  
Actual results:
Warnings about crossfire user not existing (file permissions on install)
Server won't start as crossfire user doesn't exist


Expected results:
Crossfire server starts as expected user.

Additional info:
Looks like the scriptlet still has a couple of defaults left in:

useradd -r -g crossfire -d /usr/share/crossfire -s /sbin/nologin \
    -c "Useful comment about the purpose of this account" USERNAME

Should probably be:

useradd -r -g crossfire -d /usr/share/crossfire -s /sbin/nologin \
    -c "Crossfire Server" crossfire

Cheers,
Mike.

Comment 1 Wart 2008-06-23 16:06:43 UTC

*** This bug has been marked as a duplicate of 442384 ***


Note You need to log in before you can comment on or make changes to this bug.