Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452322 - Evolution-rss cannot accept feeds from firefox
Summary: Evolution-rss cannot accept feeds from firefox
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-rss
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lucian Langa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 22:03 UTC by Peter Janakiev
Modified: 2008-07-24 02:10 UTC (History)
0 users

Fixed In Version: 0.1.0-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 02:10:29 UTC


Attachments (Terms of Use)

Description Peter Janakiev 2008-06-20 22:03:37 UTC
Description of problem:
I want to use the intelligent new system in firefox 3 that enables the user to
select which type of feed will be handled by which application. So I select Web
feed and I select as helper App /usr/bin/evolution-import-rss


Version-Release number of selected component (if applicable):
evolution-rss-0.0.8-7.fc9.i386


How reproducible:
Always

Steps to Reproduce:
1. Start firefox and navigate to a web page that has a feed - the feed icon will
be displayed in the address bar
2. Be sure to have setup the evolution-import-rss as helper app
3. press the icon for feeds and select to add the feed
  
Actual results:
The evolution-import-rss helper application does not know how to handle the
request from firefox and the feed cannot be added (cannot resolve  host name)

Expected results:
Successfully add the feed in evolution

Additional info:

In the console the following message can be seen
!!!PING!!!
Ping received from :1.111
feed->feed_url:http://feed://malwkgad.livejournal.com/data/rss
err:Cannot resolve hostname

Test from console indicated that the evolution-import-rss executable expects the
url in plane format.
Should it be changed (the importer itself) or maybe firefox should be
configurable to not mess up the passed URL?

Comment 1 Lucian Langa 2008-07-05 08:59:09 UTC
evolution-rss-0.1.0-1.fc9 has been pushed to the Fedora 9 testing repository. 
If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution-rss'.  You can provide
feedback for this update here:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6037

Comment 2 Peter Janakiev 2008-07-05 09:25:36 UTC
Some issues remaining

firefox:
]$ firefox 
pong!

evolution:
]$ evolution
CalDAV Eplugin starting up ...
evolution-shell-Message: Killing old version of evolution-data-server...
RSS Plugin enabled (evolution 2.22, evolution-rss 0.1.0)
** (evolution:3076): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:3076): DEBUG: mailto URL program: evolution
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name
org.freedesktop.NetworkManager was not provided by any .service files
!!!PING!!!
Ping received from :1.46
350d33fc-dd0f-4bd3-54e0a584-1d6a30cd is dumped

Using the cli  with exactly the same rss address :

]$ evolution-import-rss
https://addons.mozilla.org/en-US/firefox/browse/type:1/cat:all/format:rss?sort=newest
pong!

This last one works fine. 

It works directly from firefox fine with simpler URLs (like
http://malwkgad.livejournal.com/data/rss for example) but probably something in
the parsers breaks it because of the question mark ot the colons...

Dependency Installed: WebKit-gtk.i386 0:1.0.0-0.9.svn32531.fc9
Updated: evolution-rss.i386 0:0.1.0-1.fc9
Complete!


Comment 3 Fedora Update System 2008-07-05 16:32:42 UTC
evolution-rss-0.1.0-2.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-07-06 06:11:55 UTC
evolution-rss-0.1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution-rss'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6113

Comment 5 Peter Janakiev 2008-07-06 13:14:50 UTC
It works now, great work, thanks. 

Comment 6 Lucian Langa 2008-07-06 13:25:12 UTC
Please submit your positive feedback here:

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6037

so we can push this to stable

Thanks

Comment 7 Lucian Langa 2008-07-06 13:26:50 UTC
sorry, the correct url is:

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-6113


Comment 8 Fedora Update System 2008-07-24 02:10:27 UTC
evolution-rss-0.1.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.