Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452316 - eggcups goes crazy and causes cups server access_log to be flooded with "Get-Job-Attributes client-error-not-found" errors
Summary: eggcups goes crazy and causes cups server access_log to be flooded with "Get...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: desktop-printing
Version: 5.2
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 21:21 UTC by csb sysadmin
Modified: 2018-12-01 14:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-07 01:40:27 UTC


Attachments (Terms of Use)

Description csb sysadmin 2008-06-20 21:21:09 UTC
Description of problem:

eggcups goes crazy on some systems sends requests to the cups server causing the
access_log to be flooded with messages with the error "Get-Job-Attributes
client-error-not-found":

ttau - - [20/Jun/2008:16:12:20 -0500] "POST /printers/phaser6360_bw_s HTTP/1.1"
200 145 Get-Job-Attributes client-error-not-found

Version-Release number of selected component (if applicable):

desktop-printing-0.19-20.1.el5 on the clients and cups-1.2.4-11.14.el5_1.6,
cups-libs-1.2.4-11.14.el5_1.6 on the server.

How reproducible:

Random

Steps to Reproduce:

1. Have some user login to gnome
2. Maybe print a job, maybe not, who knows
3. Wait and watch server access_log

Actual results:

Starts sending some request which causes access_log to be flooded

Expected results:

Shouldn't go crazy.

Additional info:

Here's the fix:

yum -y erase desktop-printing
killall -9 eggcups

eggcups is more trouble than it's worth. It's annoying for users because it
randomly crashes and now it's like a DDOS worm.

Comment 1 Tim Waugh 2008-06-22 09:51:40 UTC
Are you getting lots of client-error-not-found lines for the same printer and
from the same client?

Comment 2 csb sysadmin 2008-06-22 13:55:02 UTC
From different hosts and for different printer queues. The queues were
operational and the printers were operational as well. I sent the remote command
above to all of RHEL5 systems from RHN.

Comment 3 Tim Waugh 2009-02-23 12:33:44 UTC
I can see a case where you might get this message at most 8 times per job (at 5s intervals) when printing a job, but only from the host that submitted the job.  Could that be it?

Note to self: TIMEOUT_SECONDS should probably be changed to 1 in ec-cups-monitor.c, as jobs will legitimately disappear from queues for remote IPP destinations.

Comment 4 RHEL Product and Program Management 2009-03-26 16:47:43 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 6 RHEL Product and Program Management 2009-11-06 18:42:43 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 7 Pablo Iranzo Gómez 2011-07-28 16:17:15 UTC
This still happens in 5.7, having access_log to nearly fill "/" storage...

Comment 9 Pablo Iranzo Gómez 2011-07-28 16:35:50 UTC
When killing eggcups and removing the print support, the gnome startup splash stays on screen until you click on it... 

¿What should be the way to disable it and use the rpm -e 'workarround' ?

Thanks

Comment 10 Tim Waugh 2011-07-29 08:53:38 UTC
Sorry, I'm not sure.  I'd really like to be able to fix the root cause.  I need to see much more of the error_log in order to find out what's wrong.

Comment 17 Vladimir Benes 2012-07-02 12:43:15 UTC
Hi all,
we are unable to reproduce this bug. Nevertheless we used cups-1.3.7-30.el5.x86_64 from 5.8 not the one mentioned in report. Is it still an issue? If not I vote for closing this as fixed in current release.

thanks,
Vladimir

Comment 20 Jiri Popelka 2013-03-11 16:56:44 UTC
RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5.
Since phase 2 we'll be addressing only security and critical issues (no FasTracks).
This problem is neither security nor critical and we don't even know the root cause of the problem, so it's quite likely that it'll never be fixed in RHEL-5.

[1] https://access.redhat.com/support/policy/updates/errata/

Comment 22 Andrius Benokraitis 2013-10-07 01:40:27 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.


Note You need to log in before you can comment on or make changes to this bug.