Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452307 - Bug in upstream libldap causes assert in io.c:ber_flush2()
Summary: Bug in upstream libldap causes assert in io.c:ber_flush2()
Keywords:
Status: CLOSED DUPLICATE of bug 450017
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 20:09 UTC by Sean E. Millichamp
Modified: 2008-06-23 13:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 13:58:22 UTC


Attachments (Terms of Use)

Description Sean E. Millichamp 2008-06-20 20:09:05 UTC
Description of problem:

Please see original Evolution bug report where the problem manifests itself:
http://bugzilla.gnome.org/show_bug.cgi?id=512605

The resulting OpenLDAP bug report:
http://www.openldap.org/its/index.cgi/Incoming?id=5525;page=1;statetype=1

Version-Release number of selected component (if applicable):

Based on my reading of the bug report and the diff's applied to the openldap CVS
tree it looks like this would have impacted openldap versions <= 2.4.9 and <=
2.3.42 and HEAD.

How reproducible:

Tough to reproduce reliably, but very annoying and painful for Evolution users
who are trying to run Fedora and connect to their corporate Exchange environment.

Steps to Reproduce:
1. Use Evolution to connect to Exchange
2. Cause Evolution to do one or more LDAP lookups against AD for GAL/contact
lookups.
3. See a crash or repeat #2 until you do :)
  
Actual results:

It crashes.

Expected results:

It works.

Additional info:

The fix is already upstream:

http://www.openldap.org/devel/cvsweb.cgi/libraries/libldap/request.c.diff?r1=1.125.2.7&r2=1.125.2.8&hideattic=1&sortbydate=0

This is just a request to track the patch or next released OpenLDAP as soon as
possible in Fedora as this is a problem that undoubtedly impacts a number of
Evolution Exchange Connector users and provides for a frustrating experience.

Thanks!

Comment 1 Jan Safranek 2008-06-23 13:58:22 UTC

*** This bug has been marked as a duplicate of 450017 ***


Note You need to log in before you can comment on or make changes to this bug.