Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452291 - Struts2 pages not displaying properly when jsessionid times out
Summary: Struts2 pages not displaying properly when jsessionid times out
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Other
Version: 1.3.9
Hardware: All
OS: All
high
urgent
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
Depends On: 455017
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 19:02 UTC by Frank Merenda
Modified: 2008-08-21 14:43 UTC (History)
2 users (show)

Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-11 21:21:45 UTC
Type: ---


Attachments (Terms of Use)

Description Frank Merenda 2008-06-20 19:02:54 UTC
Issuetracker # 186322   

If you are logged in, and your session times out, and then you click on one of
the struts 2 links (contact us, reset password, etc), you get shown the source
of the page, not the html itself.

This is somehow caused by the jsessionId being added to the end of the url. 

See the full details in the issuetracker entry.

Comment 1 Mike Amburn 2008-07-15 18:47:54 UTC
The development team is currently migrating this function from Struts2 onto an
existing Struts implementation, which should eliminate the described experience.
Once confirmed, this BZ will be closed.


Note You need to log in before you can comment on or make changes to this bug.