Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452273 - /sys vfs block device stat fields have changed
Summary: /sys vfs block device stat fields have changed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgtop2
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 17:03 UTC by Michael Schwendt
Modified: 2014-06-18 09:10 UTC (History)
1 user (show)

Fixed In Version: 2.20.2-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 529068 (view as bug list)
Environment:
Last Closed: 2008-07-23 07:13:02 UTC


Attachments (Terms of Use)
upstream fix for F-8 branch (deleted)
2008-06-26 20:35 UTC, Michael Schwendt
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 539360 None None None Never

Description Michael Schwendt 2008-06-20 17:03:20 UTC
Description of problem:
libgtop2 calculates wrong Read/Write stats based on parsing
/sys/block/sd*/sd??/stat incorrectly with recent kernels in
Rawhide. As a result, this confuses the gnome system monitor
applet, for example, which uses the libgtop2 API.


Version-Release number of selected component (if applicable):
libgtop2-2.23.2-1.fc10.i386
kernel-2.6.26-0.72.rc6.git2.fc10.i686


How reproducible:
Always


Steps to Reproduce:
1. compare /sys/block/sd*/sd??/stat with older kernel (e.g. 2.6.23.15-137.fc8)
Or:
1. configure system monitor applet to display hard-disk Read=red, Write=yellow
  
Actual results:
/sys vfs returns more fields with different meaning, and
system monitor applet displays a graph where Read access has
the colour Write access, because it receives wrong I/O values
from libgtop2.


Example:

# uname -r
2.6.23.15-137.fc8
# cat /sys/block/sda/sda1/stat
     971     1944        2        4

Versus:

# uname -r
2.6.26-0.72.rc6.git2.fc10.i686
# cat /sys/block/sda/sda1/stat
     160      577    13262     1160        6        2       16        6        0
     683     1166

Comment 1 Michael Schwendt 2008-06-20 17:14:27 UTC
Fedora 8 is also affected (!):

# rpm -q kernel
kernel-2.6.23.15-137.fc8  (<-- GOOD)
kernel-2.6.25.4-10.fc8    (<-- BREAKS libgtop2)


Comment 2 Michael Schwendt 2008-06-24 12:57:40 UTC
Since "Status" and "Summary" of external bugzilla references
doesn't change automatically, here comes the notification that
a fix was commited to upstream svn.


Comment 3 Michael Schwendt 2008-06-24 18:08:28 UTC
Changing Version to "8", because Fedora 8 and above are affected.


Comment 4 Michael Schwendt 2008-06-26 20:35:35 UTC
Created attachment 310378 [details]
upstream fix for F-8 branch

Comment 5 Fedora Update System 2008-07-09 19:06:44 UTC
libgtop2-2.20.2-1.fc8 has been submitted as an update for Fedora 8

Comment 6 Fedora Update System 2008-07-15 12:18:55 UTC
libgtop2-2.20.2-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libgtop2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6384

Comment 7 Fedora Update System 2008-07-23 07:13:00 UTC
libgtop2-2.20.2-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.