Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452259 - evince/firefox embedding breaks badly on one odd website
Summary: evince/firefox embedding breaks badly on one odd website
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 15:58 UTC by George Karabin
Modified: 2018-04-11 07:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-20 20:15:58 UTC


Attachments (Terms of Use)

Description George Karabin 2008-06-20 15:58:04 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:  100%


Steps to Reproduce:
1. Visit http://www.lauterbach.com/cgi-bin/doc.pl?file=icretm.pdf in firefox


Actual results:

The pdf file renders outside of the firefox window, with no window manager
titlebar to grab onto. On my machine, it renders the file at about 1/4 of my
screen size. When I close the pdf via evince's file menu or killing the process
if it's off screen, firefox's document pane is filled with garbage.

Expected results:

I'd expect the pdf file to render cleanly in an embedded firefox pane, or, if
there's some problem with how the lauterbach site is serving the file, display
an error, or otherwise not paint junk to my screen.

Additional info:

I don't know if this is an evince issue or a firefox issue, or something in the
glue.

Comment 1 George Karabin 2008-06-20 16:00:56 UTC
I think that something may have been corrupt in an evince process that was
already running in the background. I did have other documents opened in other
windows. After killing that evince process, the document began embedding properly.


Comment 2 Matěj Cepl 2008-06-20 20:15:58 UTC
Thanks for letting us know. I couldn't reproduce it anyway -- just File/Save
As... window jumped on me asking where to store the PDF file.

Anyway, closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.