Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452240 - Unable to install Xen guest with multiple disks
Summary: Unable to install Xen guest with multiple disks
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda
Version: 4.6
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 14:01 UTC by Ian Campbell
Modified: 2008-07-28 13:23 UTC (History)
2 users (show)

Fixed In Version: RHEL4U7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-25 20:40:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Workaround in anaconda (deleted)
2008-06-20 14:01 UTC, Ian Campbell
no flags Details | Diff
python backtrace (deleted)
2008-06-20 14:01 UTC, Ian Campbell
no flags Details
anaconda traceback part 1/4 (deleted)
2008-07-28 13:20 UTC, Alex Zeffertt
no flags Details
anaconda traceback part 2/4 (deleted)
2008-07-28 13:20 UTC, Alex Zeffertt
no flags Details
anaconda traceback part 3/4 (deleted)
2008-07-28 13:21 UTC, Alex Zeffertt
no flags Details
anaconda traceback part 4/4 (deleted)
2008-07-28 13:21 UTC, Alex Zeffertt
no flags Details

Description Ian Campbell 2008-06-20 14:01:01 UTC
Description of problem:

When installing a guest virtual machine with more than one disk the partitions
on the xvd devices are not rescanned leading to an unhandled python exception.
Attached is the patch which we use to workaround this issue.

Version-Release number of selected component (if applicable):

Observed with 4.5 and 4.6 in a Xen guest domain.

Steps to Reproduce:
1. Create a RHEL 4 virtual machine with 2 disks
2. At disk partition page, select Autopartition.
3. At automatic partitioning page,select 'remove all partition on this system', and
select both disk for installation (xvda,xvdb)
4. Rest select default options in installation process.

Actual results:

Unhandled python exception. Screenshot attached (sorry its not terribly useful)

Additional info:

I suspect this is really a bug in parted but have filed against anaconda in the
first instance since this is the component we have patched as a workaround. I'm
not convinced two disks is the relevant factor here but that is how it was
reported to me.

Comment 1 Ian Campbell 2008-06-20 14:01:01 UTC
Created attachment 309920 [details]
Workaround in anaconda

Comment 2 Ian Campbell 2008-06-20 14:01:33 UTC
Created attachment 309921 [details]
python backtrace

Comment 3 Chris Lumens 2008-07-25 15:44:40 UTC
Please attach the complete traceback to this bug report so we can see exactly
what the problem is.  Unfortunately, you've only shown the top part which is the
least specific portion of the traceback.  Thanks.

Comment 4 Ian Campbell 2008-07-25 16:36:44 UTC
The repro steps given in the bug report I received are:
[1..5 are specific to XenServer, basiucally "create a guest with two disks, xvda
xvdb]
6. When RHEL 4.5 installation starts, At disk partition page, select Autopartition.
7. At automatic partitioning page,select 'remove all partition on this system', and
select both disk for installation (xvda,xvdb) (ref screenshot pic2)
8. Rest select default options in installation process.
9. Observe the result. 

Unfortunately the only other information they gave was the screenshot which I
passed on to you. I'm attempting to reproduce now but not having much luck. I've
added a collegue who I believe has reproduced the issue in the past to the CC

Comment 5 James Laska 2008-07-25 18:26:56 UTC
Unable to reproduce on RHEL-4/U7 doing the steps outlined in comment#1 and comment#4

Comment 6 Chris Lumens 2008-07-25 20:40:47 UTC
Closing on the basis of comment #5.  If you are able to reproduce this with the
latest update release of RHEL4, feel free to reopen this bug with additional
information and we can take another look at it.

Comment 7 Alex Zeffertt 2008-07-28 13:20:21 UTC
Created attachment 312770 [details]
anaconda traceback part 1/4

Comment 8 Alex Zeffertt 2008-07-28 13:20:49 UTC
Created attachment 312771 [details]
anaconda traceback part 2/4

Comment 9 Alex Zeffertt 2008-07-28 13:21:13 UTC
Created attachment 312772 [details]
anaconda traceback part 3/4

Comment 10 Alex Zeffertt 2008-07-28 13:21:36 UTC
Created attachment 312773 [details]
anaconda traceback part 4/4

Comment 11 Alex Zeffertt 2008-07-28 13:23:31 UTC
I've tried repro-ing this on 4.5 4.6 and 4.7 and I've found that the bug only
affects 4.5, so it must have been fixed in 4.6.

FWIW, I've attached the full traceback obtained from RHEL 4.5.


Note You need to log in before you can comment on or make changes to this bug.