Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452233 - attachment names not decoded
Summary: attachment names not decoded
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 13:07 UTC by Stepan Kasal
Modified: 2008-06-23 11:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 11:29:12 UTC


Attachments (Terms of Use)

Description Stepan Kasal 2008-06-20 13:07:31 UTC
A mail (multipart/mixed) contains attachments, each with the following type of
header:

Content-Type: application/octet-stream;
        name="=?iso-8859-2?Q?pojistky_-_=BEivot.zip?="
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
        filename="=?iso-8859-2?Q?pojistky_-_=BEivot.zip?="

The problem is that the name of the attachment is not decoded: neither when the
whole mail is viewed, nor with "v", nor as the default file name when the
attachment is saved.

I have LC_CTYPE=en_GB.UTF-8.  (LANG and other LC_* variables remain unset.)

Comment 1 Miroslav Lichvar 2008-06-23 11:29:12 UTC
Decoding of these parameters can be enabled by rfc2047_parameters option.

From the mutt manual:
   Note that this use of RFC 2047's encoding is explicitly, prohibited by
   the standard, but nevertheless encountered in the wild. Also note that
   setting this parameter will not have the effect that mutt generates
   this kind of encoding. Instead, mutt will unconditionally use the
   encoding specified in RFC 2231.



Note You need to log in before you can comment on or make changes to this bug.