Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452228 - dvdrecord goes nuts
Summary: dvdrecord goes nuts
Keywords:
Status: CLOSED DUPLICATE of bug 429386
Alias: None
Product: Fedora
Classification: Fedora
Component: cdrkit
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 12:19 UTC by Gary Thomas
Modified: 2014-01-13 00:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 10:30:59 UTC


Attachments (Terms of Use)

Description Gary Thomas 2008-06-20 12:19:42 UTC
Description of problem:

Give dvdrecord a device specifier it can't handle and it goes into
an infinite loop, spewing messages...

I had to go to another console to just break out...

Version-Release number of selected component (if applicable):

 cdrkit-1.1.6-6.fc8.src.rpm

How reproducible:


Steps to Reproduce:
1. dvdrecord -scanbus
2. dvdrecord dev=XXX ...
3.
  
Actual results:

# dvdrecord -scanbus
scsibus4:
        4,0,0   400) 'LITE-ON ' 'DVDRW LDW-811S  ' 'HS0E' Removable CD-ROM
        4,1,0   401) 'LITEON  ' 'DVD-ROM LTD163  ' 'GH5E' Removable CD-ROM
        4,2,0   402) *
        4,3,0   403) *
        4,4,0   404) *
        4,5,0   405) *
        4,6,0   406) *
        4,7,0   407) *
# dvdrecord dev=4,0,0 /tmp/file.iso
  ...
 this SCSI ID. Trying to map to old ATA syntax.This workaround will disappear in
the near future. Fix your configuration.Unable to open this SCSI ID. Trying to
map to old ATA syntax.This workaround will disappear in the near future. Fix
your configuration.Unable to open this SCSI ID. Trying to map to old ATA
syntax.This workaround will disappear in the near future. Fix your
configuration.Unable to open this SCSI ID. Trying to map to old ATA syntax.This
workaround will disappear in the near future. Fix your configuration.Unable to
open this SCSI ID. Trying to map to old ATA syntax.This workaround will
disappear in the near future. Fix your configuration.Unable to open this SCSI
ID. Trying to map to old ATA syntax.This workaround will disappear in the near
future. Fix your configuration.Unable to open this SCSI ID. Trying to map to old
ATA syntax.This workaround will disappear in the near future. Fix your
configuration.Unable to open this SCSI ID. Trying t
 ...

Expected results:


Additional info:

Comment 1 Roman Rakus 2008-06-23 10:23:46 UTC
Better way is through "dvdrecord --devices":
dvdrecord: Overview of accessible drives (2 found) :
-------------------------------------------------------------------------
 0  dev='/dev/scd0'     rwrw-- : 'TSSTcorp' 'CDRWDVD TS-H492C'
 1  dev='/dev/scd1'     rwrw-- : 'HL-DT-ST' 'DVDRAM GSA-E40L'
-------------------------------------------------------------------------

"dvdrecord dev=/dev/scd1 /tmp/file.iso"

and burn begins.
Also using SCSI address works in rawhide (cdrkit-1.1.8-1.fc10)

Comment 2 Roman Rakus 2008-06-23 10:30:59 UTC

*** This bug has been marked as a duplicate of 429386 ***


Note You need to log in before you can comment on or make changes to this bug.