Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452213 - rpm unpack error installing the package: pvm-3.4.5-12.el4
Summary: rpm unpack error installing the package: pvm-3.4.5-12.el4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pvm
Version: 4.7
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 09:38 UTC by Alexander Todorov
Modified: 2008-07-24 20:00 UTC (History)
0 users

Fixed In Version: RHBA-2008-0744
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 20:00:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0744 normal SHIPPED_LIVE pvm bug fix update 2008-07-23 16:49:31 UTC

Description Alexander Todorov 2008-06-20 09:38:19 UTC
Description of problem:
When upgrading from RHEL4.6 to RHEL4.7 unpacking of pvm package failed. This
causes the entire upgrade (up2date -fu) to exit with code of 1.
Subsequent run of up2date -fu shows other packages not upgraded.


Version-Release number of selected component (if applicable):
pvm-3.4.5-12.el4

How reproducible:
always

Steps to Reproduce:
1. Install RHEL4.6 with pvm-3.4.4-21 (@everything)
2. Upgrade to RHEL4.7 via rhn.webqa (with up2date -fu)
3.
  
Actual results:
Unpack error when installing pvm package. As a result the systems ends up with
missing pvm packages (old one removed and new one not installed due to error).

Actual error message:
 334:pvm                    ########################################### [100%]
error: unpacking of archive failed on file /usr/share/pvm3/bin/LINUXIA64: cpio:
rename


Expected results:
pvm is upgraded to newer version

Additional info:
seeing this on ia64 and x86_64, not on ppc, s390*

Comment 5 Alexander Todorov 2008-06-20 11:41:09 UTC
Steps to Reproduce:
1. Install RHEL4.6 with pvm-3.4.4-21 (@everything)
2. Remove openmpi* and lam* packages (see bug #443795)
2. Upgrade to RHEL4.7 via rhn.webqa (with up2date -fu)


Comment 6 Doug Ledford 2008-06-20 15:53:08 UTC
OK, I can see why this is happening (and it makes me wonder how the rhel3
upgrade to pvm ever got through QA, it would have the same problem...but then
again this whole process has merely proven that the rhel3 pvm update was
partially complete at best).

I'm going to investigate an alternative fix for pvmgetarch...will update this
bug shortly.

Comment 7 Doug Ledford 2008-06-20 16:07:43 UTC
OK, I've created a patch to pvmgetarch that reverts the arch naming back to what
it was prior to this update, and I've eliminated the symlinks in the package
entirely.  The problem was that the symlinks couldn't be laid down during the
upgrade because valid directories with the same name already existed from the
package being upgraded, which happens because we install the new package
*before* we remove the old files from the old package, so those directories
where in the way.  With my new patch, it should go back to working like it did
prior to the update and use specific arch directories in all cases.

Comment 12 errata-xmlrpc 2008-07-24 20:00:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0744.html


Note You need to log in before you can comment on or make changes to this bug.