Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452201 - Shutdown does not do anything
Summary: Shutdown does not do anything
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kvm
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Glauber Costa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 05:39 UTC by Michel Alexandre Salim
Modified: 2008-09-25 00:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-25 00:24:39 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2008-06-20 05:39:05 UTC
Description of problem:
Using both virt-manager and virsh, shutting down a domain does not result in
anything (tried using QEMU and QEMU-KVM)

Version-Release number of selected component (if applicable):
0.4.2-1.fc9 to 0.4.3-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Create a virtual machine, say Foo
2. Start Foo
3. virsh shutdown Foo
  
Actual results:
"Domain Foo is being shutdown" -- but nothing happens if you're watching on the
graphical console. Foo keeps running normally

Expected results:
Foo should receive an ACPI shutdown signal

Additional info:
I tried shutting down the machine (in this case, DragonFly BSD). Even when the
machine is in powered-down state, the Shutdown button does not do anything and I
had to 'destroy' the machine (perhaps that option should be renamed. Force
shutdown?)

Comment 1 Daniel Veillard 2008-06-20 08:20:24 UTC
yes confirmed, I have noticed that on F-9/KVM too but didn't chase it yet,

Daniel

Comment 2 Daniel Berrange 2008-08-21 14:22:07 UTC
This is a KVM problem. The KVM 65 in Fedora 9 doesn't send the ACPI power off event correctly. I tested rawhide KVM-70  and it works as required. F9 needs an updated KVM package....

Comment 3 Glauber Costa 2008-08-21 18:17:39 UTC
For the record, virsh will use qemu's system_powerdown monitor command to accomplish that, right ?

I'm trying it in kvm-userspace.git right now, and it does not seem to be working.
(i.e.: machine keeps running). Dan, what are you seeing exactly in rawhide to make you believe it works there? Is the machine properly stopped at there?

Comment 4 Daniel Berrange 2008-08-21 19:58:16 UTC
Yes,  libvirt will invoke  system_powerdown, which sends an ACPI event.  You need to make sure your VM does *not* pass  -no-acpi to QEMU. Depending on the guest, you may also need   acpi=force on the guest kernel command line. The guest also needs to be runnning acpid daemon.

For the record I used a RHEL-5.2 guest, on i386, and had acpi=force. With kvm-65 shutdown didn't work (no acpi event appeaed in /proc/interrupts). With kvm-70 from rawhide re-built on F9, it correctly shutdown.

Comment 5 Glauber Costa 2008-08-27 20:27:01 UTC
Please check if http://koji.fedoraproject.org/koji/taskinfo?taskID=789251 fixes
this problem.

Comment 6 Michel Alexandre Salim 2008-08-27 21:07:31 UTC
I'm currently on Rawhide; the binary RPM does not install, and rebuilding the SRPM fails:

http://koji.fedoraproject.org/koji/taskinfo?taskID=789365

due to Rawhide RPM's stricter constraint on patch fuzziness.

Comment 7 Daniel Berrange 2008-08-28 14:35:58 UTC
Confirmed that kvm-65-8_private_glommer_acpi.fc9.x86_64.rpm fixes the problem - please build for updates

Comment 8 Fedora Update System 2008-08-28 16:15:02 UTC
kvm-65-9.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kvm-65-9.fc9

Comment 9 Fedora Update System 2008-09-10 06:41:13 UTC
kvm-65-9.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kvm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7437

Comment 10 Fedora Update System 2008-09-25 00:24:31 UTC
kvm-65-9.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.