Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452200 - Firefox needs to be restarted for plugins to install
Summary: Firefox needs to be restarted for plugins to install
Keywords:
Status: CLOSED DUPLICATE of bug 437596
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-20 04:42 UTC by Torsten Ekedahl
Modified: 2018-04-11 09:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-24 18:02:39 UTC


Attachments (Terms of Use)
After restart (deleted)
2008-06-27 13:24 UTC, Torsten Ekedahl
no flags Details
Before restart (deleted)
2008-06-27 13:30 UTC, Torsten Ekedahl
no flags Details

Description Torsten Ekedahl 2008-06-20 04:42:06 UTC
Description of problem:
When firefox is started during login only the Adobe Reader plugin (nppdf.so)
is installed (which is confirmed by looking at about:config). If I then quit
firefox and start it again all the plugins are installed.

Version-Release number of selected component (if applicable):
3.0/1.fc9

How reproducible:
Completely

Steps to Reproduce:
1. Login
2. Check about:config
3.
  
Actual results:
Only one plugin installed

Expected results:
All plugins installed

Additional info:
homealone[2]mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nppdf.so
  Original plugin: /usr/lib/mozilla/plugins/nppdf.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nphelix.so
  Original plugin: /usr/lib/mozilla/plugins/nphelix.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/xine-logo.ogg
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.xineplugin.so
  Original plugin: /usr/lib/mozilla/plugins/xineplugin.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.so
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mozplugger.so
  Original plugin: /usr/lib/mozilla/plugins/mozplugger.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/nphelix.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt

Comment 1 Matěj Cepl 2008-06-20 15:19:59 UTC
Is it enough to run
mozilla-plugin-config -f -c
while firefox is still opened?

Comment 2 Torsten Ekedahl 2008-06-20 16:47:42 UTC
If I do that then I get the following:

homealone[2]mozilla-plugin-config -f -c
*** NSPlugin Viewer  *** ERROR: /usr/lib/mozilla/plugins/librhythmbox-itms-

and no loading of the plugins.

I also noted the following about the only plugin that is loaded originally:

After login about:config reports this only:

Installed plugins
Find more information about browser plugins at mozilla.org.
Help for installing plugins is available from plugindoc.mozdev.org.
Adobe Reader 8.0

    File name: nppdf.so
    The Adobe Reader plugin is used to enable viewing of PDF and FDF files from
within the browser.

MIME Type 	Description 	Suffixes 	Enabled
application/pdf 	Portable Document Format 	pdf 	Yes
application/vnd.fdf 	Acrobat Forms Data Format 	fdf 	Yes
application/vnd.adobe.xfdf 	XML Version of Acrobat Forms Data Format 
xfdf 	Yes
application/vnd.adobe.xdp+xml 	Acrobat XML Data Package 	xdp 	Yes
application/vnd.adobe.xfd+xml 	Adobe FormFlow99 Data File 	xfd 	Yes

However after restart of firefox I get instead

File name: nswrapper_32_32.nppdf.so

(the rest is the same).

Comment 3 Matěj Cepl 2008-06-20 20:16:28 UTC
Something weird. Martin?

Comment 4 Martin Stransky 2008-06-27 12:53:33 UTC
Can you reproduce it after every login?
If so, can you please attach output of:

ll /usr/lib/mozilla/plugins
ll /usr/lib/mozilla/plugins-wrapped

when plugins are and are not available in firefox?

Comment 5 Torsten Ekedahl 2008-06-27 13:24:11 UTC
Created attachment 310435 [details]
After restart

Comment 6 Torsten Ekedahl 2008-06-27 13:30:15 UTC
Created attachment 310436 [details]
Before restart

Comment 7 Torsten Ekedahl 2008-06-27 13:36:15 UTC
It happens at every login.

I have attached the output of

ls -l /usr/lib/mozilla/plugins*

before and after restart of Mozilla. I couldn't manage to get them attached 
to this comment so they are instead Comments #5 and #6.

Comment 8 Torsten Ekedahl 2008-07-10 20:38:31 UTC
Another data point:
The whole problem seems to be connected with Firefox
being restarted as part of session restoration. If I quit Firefox, log
out, log in again (which means that Firefox is not started automatically 
as it was not open when the session was closed) and *then* start Firefox, 
then all plugins get loaded.

Comment 9 Jaroslav Reznik 2008-07-29 13:24:09 UTC
(In reply to comment #8)
Yes, seems to be connected to session restoration. I have same problem - when FF
started from session, plugins aren't loaded so I have to restart and then
plugins are OK (same when started manually). I'm using KDE 4.0.5. I can provide
more information even my laptop suffering with this bug.

Comment 10 Martin Stransky 2008-10-24 12:26:28 UTC
The plugin path is configured in /usr/bin/firefox starting script and this is the way how firefox is supposed to run. The plug-ins are not configured properly if you run firefox from it's current installation dir (like /usr/lib(64)/firefox-VERSION).

It's definitely a bug in KDE.

Comment 11 Rex Dieter 2008-10-24 18:02:39 UTC
looks like another side effect of bug #437596

*** This bug has been marked as a duplicate of bug 437596 ***


Note You need to log in before you can comment on or make changes to this bug.