Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452191 - galeon won't start up with recent updates
Summary: galeon won't start up with recent updates
Keywords:
Status: CLOSED DUPLICATE of bug 451956
Alias: None
Product: Fedora
Classification: Fedora
Component: galeon
Version: 9
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 23:55 UTC by Norm Murray
Modified: 2008-06-20 06:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-20 06:39:19 UTC


Attachments (Terms of Use)

Description Norm Murray 2008-06-19 23:55:35 UTC
with updates applied up to today, galeon will no longer start up:
# gdb galeon
GNU gdb Fedora (6.8-10.fc9)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) r
Starting program: /usr/bin/galeon 
[Thread debugging using libthread_db enabled]
[New Thread 0x7fb9f77917b0 (LWP 13460)]
[New Thread 0x427c8950 (LWP 13466)]

** (galeon:13460): CRITICAL **: radio_group_set_from_value: assertion `action !=
NULL' failed

Program received signal SIGSEGV, Segmentation fault.
GaleonWrapper::Init (this=0x1a6dd90, mozembed=0x1a62a50)
    at GaleonWrapper.cpp:164
164			rv = DOMWindow->GetDocument (getter_AddRefs (domDocument));
Current language:  auto; currently c++
Missing separate debuginfos, use: debuginfo-install GConf2.x86_64 ORBit2.x86_64
acl.x86_64 alsa-lib.x86_64 atk.x86_64 attr.x86_64 audiofile.x86_64 avahi.x86_64
bug-buddy.x86_64 cairo.x86_64 dbus-glib.x86_64 dbus.x86_64 e2fsprogs.x86_64
elfutils.x86_64 esound.x86_64 expat.x86_64 fontconfig.x86_64 freetype.x86_64
gail.x86_64 gamin.x86_64 gcc.x86_64 glib2.x86_64 glibc.x86_64
gnome-desktop.x86_64 gnome-keyring.x86_64 gnome-vfs2.x86_64
gtk-nodoka-engine.x86_64 gtk2.x86_64 hunspell.x86_64 keyutils.x86_64 krb5.x86_64
lcms.x86_64 libICE.x86_64 libSM.x86_64 libX11.x86_64 libXau.x86_64
libXcomposite.x86_64 libXcursor.x86_64 libXdmcp.x86_64 libXext.x86_64
libXfixes.x86_64 libXft.x86_64 libXi.x86_64 libXinerama.x86_64 libXrandr.x86_64
libXrender.x86_64 libXt.x86_64 libart_lgpl.x86_64 libbonobo.x86_64
libbonoboui.x86_64 libcap.x86_64 libglade2.x86_64 libgnome.x86_64
libgnomecanvas.x86_64 libgnomeui.x86_64 libjpeg.x86_64 libpng.x86_64
libselinux.x86_64 libxcb.x86_64 libxml2.x86_64 nspr.x86_64 nss.x86_64
openssl.x86_64 pango.x86_64 pixman.x86_64 popt.x86_64 sqlite.x86_64
startup-notification.x86_64 xulrunner.x86_64 zlib.x86_64
(gdb) 


A quick attempt to rebuild from source in case of library mismatch errors out at
this point:
In file included from ContentHandler.cpp:157:
ProgressListener.h:75: warning: 'GProgressListener' declared with greater
visibility than the type of its field 'GProgressListener::<anonymous>'
ProgressListener.h:75: warning: 'GProgressListener' declared with greater
visibility than its base 'nsSupportsWeakReference'
ContentHandler.cpp:301: error: prototype for 'nsresult
GContentHandler::PromptForSaveToFile(nsIHelperAppLauncher*, nsISupports*, const
PRUnichar*, const PRUnichar*, nsILocalFile**)' does not match any in class
'GContentHandler'
ContentHandler.h:49: error: candidate is: virtual nsresult
GContentHandler::PromptForSaveToFile(nsIHelperAppLauncher*, nsISupports*, const
PRUnichar*, const PRUnichar*, PRBool, nsILocalFile**)
make[3]: *** [ContentHandler.lo] Error 1

Comment 1 Denis Leroy 2008-06-20 06:39:19 UTC

*** This bug has been marked as a duplicate of 451956 ***


Note You need to log in before you can comment on or make changes to this bug.