Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452188 - gcjwebplugin fails www.java.com test
Summary: gcjwebplugin fails www.java.com test
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL: http://www.java.com/en/download/help/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-19 23:09 UTC by Dennis Jacobfeuerborn
Modified: 2008-11-17 16:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-14 21:47:17 UTC


Attachments (Terms of Use)
debug output when visiting http://www.java.com/en/download/help/testvm.xml?ff3 (deleted)
2008-06-19 23:09 UTC, Dennis Jacobfeuerborn
no flags Details

Description Dennis Jacobfeuerborn 2008-06-19 23:09:26 UTC
Going to the java.com applet test
(http://www.java.com/en/download/help/testvm.xml?ff3) with the gcjwebplugin
installed results in the applet failing to initialize (see attached debug
output). Doing the same with the Sun JRE package works fine.

This site has problems too: http://www.w3.org/People/mimasa/test/object/java/clock
Here only the upper row of applets works (using applet tags) while the lower
doesn't (using object tags). Again switching to Sun's JRE fixes the problem.

Comment 1 Dennis Jacobfeuerborn 2008-06-19 23:09:26 UTC
Created attachment 309890 [details]
debug output when visiting http://www.java.com/en/download/help/testvm.xml?ff3

Comment 2 Mark Wielaard 2008-06-19 23:19:41 UTC
The java.com testvm.xml applet issue has been fixed upstream:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2008-June/002411.html

Comment 3 Lillian Angel 2008-06-20 14:46:19 UTC
http://www.w3.org/People/mimasa/test/object/java/clock - is definitely a
problem. I am looking into this.



Comment 4 Lillian Angel 2008-06-20 15:22:43 UTC
The problem is with this attibute - classid="java:tz.class"

Comment 5 Deepak Bhole 2008-11-14 21:47:17 UTC
Both of the above mentioned pages now work with the new plugin in Rawhide/F10.

Comment 6 Janne Blomqvist 2008-11-14 22:14:46 UTC
Nice; any chance to get the updated version into RHEL 5.3 as well? Currently the beta has version 1.6.0.0-0.22.b09.el5.

Comment 7 Lillian Angel 2008-11-17 16:12:27 UTC
The plugin is not included in RHEL-5.3


Note You need to log in before you can comment on or make changes to this bug.